VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
100 %
User avatar
By WelshPaul
#4918
The Grandstream GVX3275 factory reset procedure can be found at the bottom of page 105:
http://www.grandstream.com/sites/defaul ... _guide.pdf

Custom dial plan goes here:
Image

So to recap... Factory reset the phones, make sure they are running the latest firmware and set them up as described here:
viewtopic.php?f=10&t=1127&start=30#p4915

That should be the phones basic setup done! :-D
User avatar
By petertmooney
#4921
The dial plan, 9 for outside looks like it will work. But if I press any key other than 9 I get a message stating the number doesn't match the call plan.
the setup I want is rooms 1-4 are extensions 1-4 8 is reception, which I made a group of 0 with so that if they dial 0 it rings kitchen (5) reception (8) and my mobile and partners phone 6 &7).
but with dial plan I can only dial 9. Does that make sense to you? lol
User avatar
By WelshPaul
#4922
OK, the following dial plans should suffice...

Reception phone:
Code: Select all
{*1|[0-8]|9,100|9,101|9,111|9,112|9,155|9,195|9,999|9,116xxx|9,116111|9,116123|9,118xxx|9,1471|9,157[1-2]|9,08001111|9,0845464x|9,0[1235789]xxxxxxxxx|9,00xxx+|9,x+|9,\+x+|9,*x+|9,*xx*x+}
All others:
Code: Select all
{8|^x+|^*|^#}
User avatar
By petertmooney
#4925
so, I started from scratch.
upgraded al phones. added dial plan.
Re-downloaded and installed freepbx etc.
now I get this in the logs trying to connect phones:
[2017-09-18 23:58:46] NOTICE[2386] res_pjsip/pjsip_distributor.c: Request 'INVITE' from '"101" <sip:101@192.168.1.134>' failed for '158.69.250.202:5070' (callid: 554403c14d36b36cf14efd81b5100830) - No matching endpoint found
[2017-09-18 23:59:57] NOTICE[2386] res_pjsip/pjsip_distributor.c: Request 'OPTIONS' from '"sipvicious" <sip:90501@1.1.1.1>' failed for '51.15.66.80:5071' (callid: 912630719583102394331857) - No matching endpoint found
User avatar
By WelshPaul
#4926
Whoa, we seem to be jumping from one thing to the next without first resolving the issues at hand...

It looks like you are attempting to register to PJSIP, chan sip and pjsip do NOT use the same ports, they bind to different ports. Why are you trying to setup PJSIP? You still trying to get video calls working? Like I said, you want to concentrate on setting up the six Grandstream phones with the basics before proceeding to do anything else.

Once you have installed FreePBX on your PI, the only thing you should be doing (for now) is updating the modules:



Set "Allow Anonymous Inbound SIP Calls" to "No" and then setup the required extensions for each endpoint:



Once done, configure the Grandstreams* as per these instructions:
viewtopic.php?f=10&t=1127&start=30#p4915

Using these dial plans:
viewtopic.php?f=10&t=1127&start=45#p4922

I will investigate the dial plan and get back to you, it should work. Can I confirm that you have setup the extensions as single digit numbers? Room 1 = 1, Room 2 = 2 etc.

Once we have the Grandstreams setup correctly, you should then proceed to open up your FreePBX server, secure it and then register your mobiles to their extensions via whatever softphone you have installed on your mobiles.

Final stage is to install and configure the OBi110 and configure FreePBX to use it. You should have everything setup and working at this point, take a backup of your FreePBX image! From this point on, make any additional changes or implement new features as and when required. If you *Bleep* things up, restore the backup and your back up and running in minutes. ;-)

*When registering the Grandstream phones, use the local IP address of your FreePBX server.
User avatar
By petertmooney
#4927
Sorry about the jumping thing. I tend to do that lol
I am going to put a fresh install on raspberry. Then wipe all phones to factory now that they have the correct firmware and go through everything slowly, step by step :fearful:

In relation to the dial plan, yes, room 1=1 room 2=2 etc.
8 is reception, because 0 is a call group that contains reception, kitchen, and my mobile etc.
9 is for outside calls.

Still no obi arrived. can take until 25th. complete head melter.
User avatar
By WelshPaul
#4928
petertmooney wrote: Tue 19th September 2017, 12:01 Sorry about the jumping thing. I tend to do that lol
No need to apologise, I can understand and appreciate that you're keen to get it all setup and working.
petertmooney wrote: Tue 19th September 2017, 12:01 I am going to put a fresh install on raspberry.
I thought you already had done a fresh install on the PI, as indicated here? If not, navigate to "FreePBX > Settings > Advanced Settings" and set "SIP Channel Driver" to "chan_sip"

Now navigate to "FreePBX > Applications > Extensions", what's currently showing? sip or pjsip?
Image

If pjsip like shown in the image above, edit each extension by clicking on the pencil under actions:
Image

Then, click on the Advanced tab, scroll down and click on the "Change to CHAN_SIP Driver" button as shown below:
Image

Don't forget to click on the red "Apply Config"button displayed in the top right hand corner of your display.

Your basic FreePBX setup should look something like this: https://1drv.ms/v/s!AusdiKa87-PC9uJfBeZsO8kY1cmKmg
Using the above setup, I managed to register a Snom D715 against extension 8 (Reception) and my iPhone against extension 6 (My Mobile). Now, press 6 on the reception phone and my iPhone rings, press 8 on my mobile and reception rings, press zero on the reception phone and extensions 5, 6, 7 and 8 ring. In the video you can see both the Snom (line 2) and my iPhone ring when pressing 0, that's because I haven't registered any phones to extensions 5 and 7. Video here: https://1drv.ms/v/s!AusdiKa87-PC9uJg32dZrqTZn2xNSw

Like I said, keep it simple and stick to the basics for the time being. :P
User avatar
By petertmooney
#4929
I had done a fresh install. but used the beta. and it kept showing pjsip in the logs even though the chan sip driver was in use.
I removed and readded extensions repeatidly to no avail.
have normal rom on now.
Everything wiped. most guests seen to, gonna start again now.
User avatar
By WelshPaul
#4931
Before you give up on it completely, send me the external IP address and admin login credentials via a private message and I shall set it all up for you. Remember to allow outside access to your FreePBX server first otherwise I won't be able to connect to it! :)
User avatar
By WelshPaul
#4932
Hi Peter, thanks for the private message and for providing me with the login info requested. I'm confused as to why you're still running the Beta? You have also installed every module know to man, including some commercial ones? You should be installing and running this image and only updating existing modules.

If you install the correct RasPBX image onto the SD card and boot up the PI, I will proceed to set it up for you. I'm not going to waste my time (or yours) configuring any alpha or beta images, there are likely still many bugs/issues that need ironing out. As such, those images are still in testing, never use them on a live server! ;-)

FreePBX 13 is rock solid, no reason not to use it! You can easily upgrade to FreePBX 14 once a final, more stable build has been released for the Raspberry PI. :thumbsup:
  • 1
  • 2
  • 3
  • 4
  • 5
  • 6
  • 9

Attached below is my latest OBIHAI UK configuratio…

System advice?

As you wanted 9 for an outside line, pretty sure t…

Getting IP address from SIP

Yes and yes (unless they change it). Try pinging …

OK, another update... This time I have overhauled…