VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
100 %

Advertisement

By Sponsor

Advertisement

By Sponsor
User avatar
By WelshPaul
#4935
Currently upgrading your system and applying the necessary configuration changes. When viewing the logs, I see that you have a telephone registered against extension 8? I shall shortly register a telephone against extension 1 and make a test call. Don't be alarmed if the phone registered to extension 8 rings (no need to answer).

Your Raspberry PI will reboot a few times too, so don't worry if your phone drops registration a few times.
User avatar
By WelshPaul
#4938
OK, I have it setup and configured correctly. I have a remote Snom phone registered here against extension 1, my mobile against extension 2 and calls between them are fine, they both hold registration without issue. Extensions 6 and 8 also shown as registered. Can you try dialling *43 from them? You should hear a message informing you that you're about to preform an echo test... Speak into the phone and your voice should be played back to you? Working here! :)
petertmooney wrote: Wed 20th September 2017, 14:13Should be a phone registered to all extensions. All powered on and connected.
Are these phones using a local IP address to register or the external one? I'm guessing that these all use your WiFi network? Try power cycling the phones.

UPDATE @16:43: The Snom phone is still registered to extension 1, extension 6 just called it. Now that I know it holds registration I will unregister it so that you can register your own handset against it.
User avatar
By petertmooney
#4940
Image
Image

First of all, Thank you so much for doing that. You pretty much did what I did, but tidier lol

The above are screenshots of kitchen phone. All credentials are correct, worked at one stage. dunno why not now, they are all pretty much like that.

Would it be in any way the settings we did to stop random callers?
User avatar
By WelshPaul
#4942
First, you should be registering all internal phones to the local IP of your FreePBX server (e.g. 192.168.1.254) and not the external ddns.net address. That's like sitting in your living room and you decide to get up and ring your doorbell only to walk past it at the front door and get into your car, drive a 100 miles down the road, go round a roundabout and drive another 100 miles back home to get out the car and ring the bell.

Can you not factory reset one of the phones and set it back up from scratch? As above, use the local IP address of your Raspberry PI and not the ddns.net address along with the user ID and password. See if it connects...
  • Account Name: Kitchen
  • SIP Server: 192.168.1.x <<<Replace with Raspberry PI local IP
  • SIP User ID: 5
  • SIP authentication password: Extension Password/Secret
Once registered, dial *43 and make sure you can perform a successful echo test on each extension.
petertmooney wrote: Wed 20th September 2017, 19:46 Would it be in any way the settings we did to stop random callers?
Possibly, I forgot about those changes! Then again, Extension 8 is registered. Didn't you make the same changes to that phone too?

It's possibly this that's preventing registration: SIP Settings: Only Accept SIP Requests from Known Servers : Y
petertmooney wrote: Wed 20th September 2017, 19:46 First of all, Thank you so much for doing that. You pretty much did what I did, but tidier lol
I did a lot more, most of it was done via SSH server side. Installed server updates, fail2ban etc. Check your PM's too!
User avatar
By petertmooney
#4943
Just seen the private messages now lol I'm completely useless at this stuff lol
Thanks so much again.
I reset kitchen phone and changed it to use internal ip address. that seems to have worked!
Gonna now go in to settings for blocking random callers and see what happens.
User avatar
By WelshPaul
#4944
petertmooney wrote: Wed 20th September 2017, 20:19 Just seen the private messages now lol I'm completely useless at this stuff lol
Thanks so much again.
I reset kitchen phone and changed it to use internal ip address. that seems to have worked!
Gonna now go in to settings for blocking random callers and see what happens.
Make sure you perform those echo tests too! ;-)
User avatar
By WelshPaul
#4946
petertmooney wrote: Wed 20th September 2017, 21:25 is it possible the dial plan caused the issues?
What issues? Registration? Nope! Always possible that there is a bug in the firmware though. Is everything working as it should now? Thinking about it, I forgot to mention earlier that you want to set the Register Expiration (m) period on the phone to 60 seconds (1 minute), phones may loose registration otherwise (how could I forget that!?!). :x

Image

On another note, you also want to restrict external access on your Raspberry PI to only allow access to ports, 5160, 5160 and 10000 - 20000. I would configure your port forwarding accordingly! That way you can register an endpoint remotely but not access the server via SSH and it's GUI. LOCK IT DOWN!!! ;-)
User avatar
By petertmooney
#4947
Kitchen, front desk, room one, and both mobile phones seem to be now working. Cant get looking at the other rooms until these guests check out. Nasty people they were too. I asked if they'd mind if I took the phone from there room to repair it and they told me to go away and slammed the door in my face. Eviction notices were at the ready. lol
User avatar
By WelshPaul
#4948
petertmooney wrote: Thu 21st September 2017, 07:31 Kitchen, front desk, room one, and both mobile phones seem to be now working.
Great news. :thumbsup:
petertmooney wrote: Thu 21st September 2017, 07:31Cant get looking at the other rooms until these guests check out. Nasty people they were too. I asked if they'd mind if I took the phone from there room to repair it and they told me to go away and slammed the door in my face. Eviction notices were at the ready. lol
Wow! Some people are so rude!! :-o

FYI, you don't need physical access the phones in order to configure them. All you need to do is enter the phones IP address into your web browser. If you don't know the IP, your router should have a list of all assigned IP address where you can get it from. Of course, the phone needs to be connected to your internal network for this to work, and although they are not currently registered with your FreePBX, they should still be registered to your WiFi hot spot. ;-)

You should change the phones GUI login credentials too (if not done so already), otherwise if you allow guests to use your WiFi, all they need to do is enter the phones IP address into their browser and login with the default values and they have access to your phones configuration and VoIP credentials.
User avatar
By WelshPaul
#4949
Hi Peter,

As you grant access to your FreePBX server to remote endpoints, you should read these:

https://www.theregister.co.uk/2017/09/0 ... ted_calls/

http://nerdvittles.com/?p=23361

While I did implement all patches and updates on your server, it's worth being aware of this venerability in case it's ever introduced again in any later release of asterisk. Because of this, I just logged back in to your FreePBX server and updated extensions 1 -5 (Advanced) with the following change:
  • NAT Mode: No - (no)
It's the default value, it was changed to "Yes - (force_rport,comedia)" because you were originally registering externally using the ddns.net address. As these extensions now use the internal IP address of your Raspberry PI there is no requirement for NAT Mode to be set to yes. I did see that extension 8 is still registered via the ddns.net proxy address, you should change that to the local IP address of Raspberry PI too, just like you did with extensions 1-5. Once done, edit extension 8 on your FreePBX server and under the Advanced page, change "NAT Mode: Yes - (force_rport,comedia)" to "NAT Mode: No - (no)".

Leave extensions 6 & 7 alone, if you change the NAT Mode on those to no, you will likely loose audio on any calls made via these extensions.

Advertisement

By Sponsor
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7
  • 9

In the past month, Microsoft have changed their sp…

Porting NGN Issue...

Hi WelshPaul, thanks for the replies and your ef…

Not at this time no. :dunno: Having just looked…

Hello, I have a Google Voice number as well as …