VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
User avatar
By pebblar
Posts Likes Avatar Topics
My handset (Gigaset S650H PRO) occasionally rings but there is no one on the other side when I answer. There was a spate of these in the early evening a few months ago and I didn't work out what they were, but I've had another today.

The screen displays the ringing bell icon, but the number on the screen never looks like a phone number (today's was 1959954216) and I assume is a code rather than a number.

it also doesn't display the usual format:

from number xyz

from number xyz repeated
for ext. abc

reject / silence

But has the one number once and reject / silence options.

When I reject it has a code - I went to take a photo with my mobile, but it cleared before I could. There was some error text and the number 814.

Any ideas what this is and why I get them?
Teodor liked this
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
Ahh those pesky phantom calls / SIP scanners! :rolling_eyes:

These calls are NOT coming through your provider. The fact that your phone rings proves unsolicited packets (tcp or udp) from the internet can reach your VoIP device. This can be the result of port scanning or UDP flooding. In most cases the attacker can't do much other than to create a bit of nuisance in your household. If your device is capable of some form of call forwarding (even from voicemail ivr), then there is a remote chance that your account may be used to call premium numbers (owned by the hacker on a revenue sharing basis) overseas.

It is not possible to retrieve data from your Gigaset device, but it is an security risk caused by your internet router.


1. Router configuration:

The solution has to be created in your router, below are steps you need to check.
  • Do not place your VoIP device in an DMZ (Router configuration)
  • Disable uPnP and one-to-one NAT (full cone NAT) in the router
  • Remove all port forwarding to your VoIP device on your router
  • NAT router unless you have some funny stuff running on your PC
  • Upgrade your router with the latest firmware
  • Sometimes less expensive routers have also poor Firewalls and NAT functionality
2. Change local SIP port

In the web-interface of your device go to: Settings - Telephony - Advanced VoIP Settings and change the SIP port on your VoIP device to something other than 5060-5080


3. Disable IP dialling on Gigaset phone:

This change will take care that your gigaset phone won't ring, but the root cause is not solved and needs to be changed, see router configuration.

3.a Via activation code:

You can't disable this feature via the web-interface, therefore we created a special config that can be loaded via activation code.
  • On an handset go to: Settings - Telephony - VoIP Wizard
  • Handset shows "Start IP installation wizard", press "Yes" to confirm
  • Press OK to confirm
  • Select an IP account, please use not used account but if all are used also existing account can be used.
  • Handset shows "Do you have a code for auto-configuration"
  • Press "yes" to confirm
  • Enter the code: 911910
  • Device downloads small config file that disabled IP dialling
  • Handset will show that it tries to register and it not working but you can regard this message.
  • End wizard with pressing "red" end key.
  • IP dialling is disabled.
If this does not work, please check the following:

In the web-interface of the device, check if the Dataserver has the correct setting: profile.gigaset.net/device


3.b Via auto provisioning:

You can disable the IP dialling option when the device is in an business environment configured via autoprovisioning, the following parameters needs to be changed:


Source: https://teamwork.gigaset.com/gigawiki/p ... =336560276
Teodor liked this

A Hook Flash is nothing more than hanging up and picki…

Thank-you extremely helpful. What would I do if for s…

Am not sure where my Grandstream HT813 was sourced from…

My HT801 was configured for another UK provider. I rea…

Sign up for VIP membership