VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
User avatar
By Fred Thompson
Posts Avatar Topics
#6039
I am trying to use a Cisco SPA232D with the Irish phone system.
I have been trying for some time to get it to work properly with different impedance and gain settings.
My PSTN line is via a Vodafone modem/router...for which nobody seems to know the line characteristics.
My system works well except that occasionally it mis-dials numbers by adding a digit or two at the start of the number.
ie. dial 0216666666 and it dials 33021666, which is recognised by my dial plan as a local number.
The 232D interface shows that the number has been sent by the ATA correctly, so problem must be in the gain/impedance match with the PSTN line. I have tried the suggested UK settings on this site.
I am currently using FXS i/p gain -12, FXS o/p gain of -8 (when i use higher values here, the ATA seems to detect incorrect number from the FXS phone)
I am using SPA to PSTN gain of 3, and PSTN to SPA gain of 6.
I have tried a huge variety of parameters, but find that about once a day (oddly normally first call of the day) the dialled number is sent incorrectly.
I would be very grateful if anyone could help me out with a suggestion.
Thank you.
0
User avatar
By Fred Thompson
Posts Avatar Topics
#0
Thank you again Paul,

The post in the Cisco community was posted by myself before i discovered this forum.
Based on your very helpful post, i have found a copy off the Obi settings for Ireland and made some very small changes. They are mostly as you suggest.
I finally broke down and used an oscilloscope to trace the signal levels for the Phone direct to Vodafone router. I then connected the ATA and changed the SPA-PSTN gain levels until I got an exact match. The correct level for me seems to be SPA-PSTN gain minus 2 ( -2 ). I have left the PSNT-SPA gain at zero. Also FXS I/P gain plus 3 ( +3 ) and FXS O/P gain minus 3 ( -3 ).
These settings have worked since I changed them last night.
Fingers crossed that they continue to work!
Thanks for pointing me in the right direction.
Regards & Happy Christmas
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6040
Fred Thompson wrote:My PSTN line is via a Vodafone modem/router...for which nobody seems to know the line characteristics.
If your main phone service supplied by Vodafone exits via the router then you have a Digital Voice service (VoIP). So, you don't have a PSTN line plugged in to the PSTN line port of the SPA232D, you have a cable running from the routers FXS port to the PSTN line port on the SPA232D?

As you mention above, Vodafone are the only ones that know the true line characteristics and so it will be a case of trial and error unfortunately.
A Google search returned the following result: https://community.cisco.com/t5/atas-gat ... -p/4087954
0
User avatar
By Fred Thompson
Posts Avatar Topics
#6041
Thank you Paul.
You are absolutely correct that it is the FXS port from the Vodafone modem connected to the PSTN port on the ATA.
I had (obviously incorrectly) concluded that the modem FXS port behaved exactly as a PSTN line.
I guess I will have to continue my trial and error of the parameters.
Do you have any general suggestions for Cisco FXS gains or SPA to PSTN gains that might fix the extra digits appearing at the beginning of the dialled number?
Thanks again.
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6042
Fred Thompson wrote:I had (obviously incorrectly) concluded that the modem FXS port behaved exactly as a PSTN line.
Nope - Most Internet Telephone Service Providers don't even configure their devices with the correct UK parameters (Vonage springs to mind) let alone follow a set standard. Configuration varies from provider to provider! If Vodafone have altered the default gain settings on their hardware then you need to compensate for that on the Cisco SPA232D.

If one is using a UK PSTN line, then in almost all cases the following configuration will work just fine...

Both FXS Port Input Gain and FXS Port Output Gain is almost always 0. I almost never need to change these!
SPA To PSTN Gain and PSTN To SPA Gain, I leave both set at their default settings which is 0.

These should be good too:
  • Voice > Regional > Control Timer Values (sec)
    • Hook Flash Timer Min: .06
    • Hook Flash Timer Max: .2
    • Interdigit Long Timer: 6
    • CPC Duration: .09
  • Voice > Regional > Miscellaneous
    • FXS Port Impedance: 370+620||310nF (or 270+750||150nF )
    • FXS Port Input Gain: 0
    • FXS Port Output Gain: 0
    • Caller ID Method: ETSI FSK With PR(UK)
    • Caller ID FSK Standard: v.23
  • Voice > PSTN > PSTN Disconnect Detection
    • Detect CPC: yes
    • Detect Polarity Reversal: no
    • Detect PSTN Long Silence: yes
    • PSTN Long Silence Duration: 30
    • PSTN Silence Threshold: High
    • Min CPC Duration: 0.09
    • Detect Disconnect Tone: yes
    • Disconnect Tone: 400@-30,400@-30; 2(3/0/1+2)
  • Voice > PSTN > International Settings
    • FXO Country settings: UK
    • Ring Validation Time: 256ms
    • Ring Indication Delay: 512ms
    • Ring Timeout: 640ms
If it was me, I would be looking at both the Gain and DTMF Tx Method settings. Without knowing what the Vodafone ATA is configured to use it will be a case of trial and error unfortunately! After all, It wouldn't be a delay issue otherwise you would be missing numbers and not gaining some, and it won't be a line noise issue either. Oh, It might be worth looking at the Obihai UK settings too as they are almost identical to the Cisco hardware (same people made them).

What's interesting is that the poster in the link I provided above had an identical issue to yourself. They said that they replaced the SPA232D, tried a different handset and yet still the issue persisted. That makes me wonder if there is a bug in the firmware... Are you using the latest firmware? If you do have the latest firmware, maybe try a lower revision and see if the problem goes away?
0
User avatar
By Fred Thompson
Posts Avatar Topics
#6043
Thank you again Paul,

The post in the Cisco community was posted by myself before i discovered this forum.
Based on your very helpful post, i have found a copy off the Obi settings for Ireland and made some very small changes. They are mostly as you suggest.
I finally broke down and used an oscilloscope to trace the signal levels for the Phone direct to Vodafone router. I then connected the ATA and changed the SPA-PSTN gain levels until I got an exact match. The correct level for me seems to be SPA-PSTN gain minus 2 ( -2 ). I have left the PSNT-SPA gain at zero. Also FXS I/P gain plus 3 ( +3 ) and FXS O/P gain minus 3 ( -3 ).
These settings have worked since I changed them last night.
Fingers crossed that they continue to work!
Thanks for pointing me in the right direction.
Regards & Happy Christmas
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6044
Fred Thompson wrote: The post in the Cisco community was posted by myself before i discovered this forum.
I didn't look at the poster information. I'm so used to reading threads over on the Cisco forum that are years old that I rarely look anymore. :thinking: 😆
Fred Thompson wrote: I finally broke down and used an oscilloscope to trace the signal levels for the Phone direct to Vodafone router. I then connected the ATA and changed the SPA-PSTN gain levels until I got an exact match. The correct level for me seems to be SPA-PSTN gain minus 2 ( -2 ). I have left the PSNT-SPA gain at zero. Also FXS I/P gain plus 3 ( +3 ) and FXS O/P gain minus 3 ( -3 ).
Thanks for taking the time to reply with a possible solution. This will be helpful to others as I expect to see more posts like yours further on down the road as the old copper pair is slowly being replaced with VoIP.
0
Sipgate Basic and multiple SIP clients

Ok, thanks. Was worried that using the same sip user in…

Your device was probably listed on Cisco's provisioning…

This means it is very dangerous to post here other t…

https://www.ukvoipforums.com/viewtopic.php?t=58#p5950

Sign up for VIP membership