VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
User avatar
By LenCuff
Posts Likes Avatar Topics
#6474
Have had Sipgate basic for a while and all worked fine until a few days ago. Phone still works fine as does voicemal but then I try calling any of the test numbers or 55000 for voicemail I'm getting no response at all?
Call the number and it rings and works fine so are Sipgate having issues or is this problem at my end?
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6475
Is it working for you now? I just called 10000 and 55000 using Zoiper on my mobile and it connected right away...

To confirm, inbound calls work? Can you successfully call out to landline numbers and mobiles ok too?

If I remember you're using a Huawei 4G router with a Lebara SIM to provide an internet connection alongside a Grandstream HT812. Can you tell me if SIP ALG is enabled on the router? If it is, try disabling it and if it isn't, try enabling it and see how you get on. Failing that we will need to run a SIP trace to find out what's going on here.
0
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6477
So far, all the Huawei 4G and 5G routers I have tested break SIP/VoIP if SIP ALG is disabled.
Anyway, great to hear that you're back up and running! 👍
0
User avatar
By LenCuff
Posts Likes Avatar Topics
#6502
So after the time change over the weeekend this problem has reappeared! I've checked all time settings and also SIP ALG is on but although calls work I'm getting no response from any numbers - 55000 or 10000 ?
Can someone confirm they get a response from these numbers please and then suggest what might be going on?
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6503
Hi @LenCuff, I did check those numbers yesterday and they were and still are working for me. This is something on your end for sure...

Under the "PROFILE1/2" page, what do you have "NAT Traversal" configured to use? Try setting it to "Keep-Alive" and remove any STUN server if configured.
0
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6505
Is it just those numbers that you have issues with? Everything else works just fine?
0
User avatar
By LenCuff
Posts Likes Avatar Topics
#6506
When this problem happens it appears that I can't call any numbers. I don't have credit on this account so never actually use it for outgoing calls but I can always get incoming calls whether this problem is there or not.

I don't want to make any changes as it's all working again, maybe it's just a glitch as it had worked for a long time and the only thing that changed was going to BST over the weekend?
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6507
You should try and identify the cause otherwise it's likely going to keep raising its ugly head over time. 😔

Can you confirm for sure that registration hasn't failed (can take a while to show as failed depending on registration expiry time settings) and that Inbound calls are working just fine at the time outbound calls are failing? I would remove any STUN server setting and set NAT to Keep-Alive and see how things go. If it happens again then just revert the two changes and debug further? Given that you're using a 4G router to provide internet access around your home it could be a network performance or congestion issue, such as network latency, or not enough available upload bandwidth at the moment of the call. (A SIP trace would be most helpful at this point in time.)
tonygibbs16 liked this
0
User avatar
By tonygibbs16
Posts Likes Avatar
#6508
Hi LenCuff

If you would like to do test with me, between 2 Sipgate Basic users so I think that the calls would be free, then please direct message me and we can do some test calls.

I read that Sipgate Basic wanted SIP ALG to be off, as it does not always work in routers.

I have my Grandstream HT812 ATA set-up to NAT keep alive and "Use NAT IP" set to my public IP address under Profile 1, so that I it goes in the INVITE dialogs and I don't need to use STUN.

I hope that this is helpful.

Kind regards,
Tony
0
User avatar
By LenCuff
Posts Likes Avatar Topics
#6525
I think the problem was down to my stupidity! I have a timer on the router to reboot once a day and the grandstream an hour later. As I didn't change the timer settings it looks like they were
both rebooting at the same time causing problems. I've now set the grandstream to an hour later and the problem hasn't reappeared!
tonygibbs16 liked this
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6526
tonygibbs16 wrote: Wed 30th Mar 2022, 16:02 I read that Sipgate Basic wanted SIP ALG to be off, as it does not always work in routers.
I myself always recommend turning off SIP ALG but @LenCuff is using a Huawei 4G router. I know from experience that a SIP profile will not register on a Huawei router unless SIP ALG is enabled (well, on all the one's I have tested). I don’t even know if Len is using the built in telephone port on his Huawei router? Probably not, and so disabling SIP ALG may be possible. However, in a previous post he did state that he had issues with registration and/or incoming calls because SIP ALG had been disabled, and that enabling SIP ALG resolved those issues.
tonygibbs16 wrote: Wed 30th Mar 2022, 16:02 I have my Grandstream HT812 ATA set-up to NAT keep alive and "Use NAT IP" set to my public IP address under Profile 1, so that I it goes in the INVITE dialogs and I don't need to use STUN.
Some great advice there...
In @LenCuff case, I would advise against entering any external IP into the "Use NAT IP" field. Again, this is because he's using a Huawei 4G router with a Lebara SIM, on the Vodafone UK mobile network. His external IP is most likely utilising CGNAT and is dynamic. It's likely changing several times a day unlike fixed broadband (ADSL,FTTC, FTTP, etc) providers who's dynamic IP's don't change unless you reboot the router.
LenCuff wrote: Thu 7th Apr 2022, 10:37 I think the problem was down to my stupidity! I have a timer on the router to reboot once a day and the grandstream an hour later. As I didn't change the timer settings it looks like they were
both rebooting at the same time causing problems. I've now set the grandstream to an hour later and the problem hasn't reappeared!
Hmm, but you've had this problem prior to the clocks changing too? If it's still working then leave things be for now I guess. If it ain't broke! 🤞
tonygibbs16 liked this
0

My HT801 was configured for another UK provider. I rea…

Sip to PSTN lines gateway

Hi All I am looking for a gateway that will allow a le…

Hi all! We have Cisco 7941 phones that we are battlein…

TalkTalk -residential VOIP

Do not touch it. No incomming caller ID no call rou…

Sign up for VIP membership