VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
By Trustever
#714
Dear All,


I have done some reading on this forum and in the main Obihai forum and I have been able to configure my OBI110 to use my voip number provided by messagenet. Everything was fine, I had received few calls I could hear them and they could hear me with no problem.

Being happy and probably too confident I decided to set up also a second service (freecall) to make outgoing calls as I have some credit where with messagenet I have no credit. Once I have done the set up this service was not working, I have played with some of the settings without success to the point that I thought it would have been better to start from square one.

I did reset the Obi110, imported the UK settings in the xml file (thanks Paul to set them up) and reconfigured messagenet but this time if I call the number it rings but I can not hear any audio at all.

Can someone kindly assist me on what is going wrong?

Configuration parameters from the website are:

Display Name: your name
Username: your unique personal identification code (also called URI) that you received via email from Messagenet after registering
Authorization User: as above
Password: the password you received via email from Messagenet after registering for FreeNumber or SmartNumber.
Domain/Realm: sip.messagenet.it
Sip Proxy: sip.messagenet.it:5061 or sip.messagenet.it:5060
Send Internal IP: Always

and this is what I have at the moment:
Screen Shot 2014-10-01 at 00.09.47.png
the XXXXX in the saved settings is my URI for both fields.
Screen Shot 2014-10-01 at 00.10.45.png
User avatar
By WelshPaul
#717
You say you have no credit on your messagenet account? Are you sure any free trial or free credit hasn't come to an end?

Are you configuring your OBi device via the obitalk portal or it's local web based GUI?

Try resetting the OBi again and this time log in to the devices GUI by entering it's IP address into your web browsers URL. Now configure the device with the following:

ProxyServer: sip.messagenet.it
AuthUserName: XXXXXX
AuthPassword: ******
URI: Leave this field empty for now, if it still does not work enter the following: XXXXXX@sip.messagenet.it

Obviously the XXXXXX in the above represent your Username credentials and ****** represents your password. Submit the changes and reboot! See if that works, if it does just upload the UK settings XML and take it from there.
User avatar
By WelshPaul
#720
Hmm ok... I was going to setup an account and test it on a 202 but messagenet want a copy of my passport and no way am I sending them a copy of that.

Try also adding: RegistrarServer: sip.messagenet.it

There shouldn't be any need to add it unless the registrar server is different from that of the proxy server.
By Trustever
#721
Paul,

first Problem sorted, I have detached the cable for the phone and messagenet got registered and had the phone ringing and all the audio.
Now I have the problem 2: I need to configure the outbound calls with an other provider this is the freecall (part of the dellmont group), I have just configured the service according to the instruction they have on their website
https://www.freecall.com/sip/

but it gives me this error

Register Failed: 403 Try later (server=212.97.59.76:5060; retry in 13s)

naturally the phone line has been detached. Any suggestions?

Further let's say this will register how can I make a call using this account? In the past I used to ring a local number and than had to input the international one, will I now be able to dial the international directly?
User avatar
By WelshPaul
#722
First of all a 403 is usually related to an incorrect username/password. Can you check the username and password for that VoIP account and make sure they have been entered correctly?
User avatar
By WelshPaul
#724
Ah wait a minute... yes of course... :oops:

Under the 'SPx' profiles you need to change 'X_ServProvProfile' parameter to point to the correct ITSP Profile.

EDIT: sorry I pressed submit to soon -

An example:
  • ITSP Profile A is set for messagenet, SP1 is also messagenet so under SP1 > X_ServProvProfile A

    ITSP Profile B is set for Freecall, SP2 is also set for freecall so under SP2 > X_ServProvProfile B
Submit the changes then reboot device.
User avatar
By WelshPaul
#726
Trustever wrote:How do I dial out using ITSP Profile B (freecall)?
If you want all outgoing calls to go via freecall just log into the GUI and go to:

Physical Interfaces > Phone Port > and change 'PrimaryLine' to whatever you have freecall registered against!

If you have freecall registered against SP2 then change the PrimaryLine parameter to SP2.

Remember to submit the changes and click reboot.

I recommend you read this: http://www.obihai.com/faq/About-the-OBi ... s-with-OBi
By Trustever
#727
Perfect, now I can make calls without need to ring that number of theirs...

Last in the list is to set back up my landline. I assume I need to import the UK settings from the xml file, right?

To be on the safe side can I back up all the settings that I have so if I need to factory reset the OBI I can get back to this point in time?
User avatar
By WelshPaul
#728
Trustever wrote:To be on the safe side can I back up all the settings that I have so if I need to factory reset the OBI I can get back to this point in time?
Yes, it's easy to do. :thumbsup:

Log into the web based GUI and navigate to:
System Management > Device Update > and under 'Backup Configuration' click on the 'Backup' button. (Leave the three check boxes above empty) This will download an XML file containing everything you added/changed so far but it does not save/backup any passwords. When you restore your settings using this XML file you will need to manually enter any passwords you changed/inserted manually.

Once you have your backup saved simple restore the UK XML file, nothing in that file will overwrite anything we have done so far.
User avatar
By WelshPaul
#730
I take it your calling your landline from your mobile? You can hear the 'ring ring' in your mobile phones ear piece but your DECT phones are not ringing?

Do you have one of these connected between your OBi110 and DECT phone: http://www.broadbandbuyer.co.uk/product ... r-rjp-bts/ or is your DECT phone connected directly to the OBi110?
Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests

Landline bridge advice

Factory reset your OBi after updating it's firmwar…

Yep, good phones too! The Cisco SPA phones are na…

Hi Phil, Thanks for coming back to us and confirm…

Grandstream GXP1610 IP Phone

Description - Grandstream GXP 1610 IP Phone HD w…