VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.


By Sponsor
By brackenhill_mob
I didn't want to clutter up Paul's posts about UK settings as I feel those posts are best left as definitive answers. However ...

Having uploaded the UK specific XML file, I've been tearing my hair out trying to work out why calls coming in on the PTSN (ie BT) line of my OBi110 were ringing the phone once and then dropping the call. The caller still heard the ring tone and the call itself was never being terminated.

Fortunately if I reset the system so that everything was for the US market, the phone rang as it should (with US ring tones) so I knew that the issue was one of the UK specific settings.

It turns out that the setting for CPCTimeThreshold in the Physical Interfaces | Line Port section is very sensitive. The default/suggested UK setting of 9 (9 milliseconds) is far too low. Occasionally it worked if set to 10 but not consistently. I've currently set it to 20. It worked happily with the default of 450 so I've got room to play with!!

Best answer by WelshPaul » Thu 9th Oct 2014, 12:50
I have the updated XML here: viewtopic.php?f=29&t=313&p=630#p630

View Post


By Sponsor
User avatar
By WelshPaul
Not sure why the OBi1xx series is so touchy about that setting.

We have come to the conclusion long ago that on the OBi1xx series the best value to use is 90. I thought I had updated the original post informing users of this? (I will check) As for the XML file maybe we should update the value to 90 their also. I will look into this shortly.

The official UK setting is 'Min CPC Duration: 0.09' but 0.09 is not a valid entry on the OBi1xx series. We tested it with the value of 90 and it worked within spec at that value.
User avatar
By WelshPaul
I know where we have gone wrong!

OBihai stuff need the value in 'ms' and not seconds like the Cisco stuff... So 0.09 seconds = 90 milliseconds

The correct value for the 'CPCTimeThreshold' parameter therefore is '90' as shown in my conversion above. I see we also got the values wrong on the 'CPCDelayTime' parameter and the 'CPCDuration' parameter as the correct values here should be:

CPCDelayTime = 2000
CPCDuration = 100

So 2 seconds for the CPCDelayTime parameter, and .1 second for the CPCDuration. Remember OBi's need the value in milliseconds not seconds so 2 seconds = 2000 and .1 second equals 100 milliseconds.

Will email Mark over at OBIHAI and get this fixed.
User avatar
By WelshPaul
brackenhill_mob wrote:Want to mark this as solved as I can't?
I have now implemented a solved topic feature; moderators and admins can mark topics as solved. I have disabled members from being able to mark and unmark topics as solved for the time being but will enable the feature soon. I have at your request marked this topic as solved and closed it. :thumbsup:

Also for the record I would recommend you upload the XML file to your device again as it was brought to my attention here: http://www.obitalk.com/forum/index.php? ... 9#msg58259 that the DisconnectTonePattern parameter was incorrectly set for 20 seconds instead of the correct value of 2.

I have spent a while going through the XML file today confirming everything and i'm confident that everything is as it should be now.
(At Last :*Bleep*: )


By Sponsor

Vonage don't allow you to use your own equipment w…

Great to hear you used one of many Flextel feature…

Supported Products: OBi200 OBi202 OBi300 OB…

Due to high bandwidth usage (over 1TB a month) and…

Sign up for full membership