VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.

Advertisement

By Sponsor

Advertisement

By Sponsor
User avatar
By WelshPaul
#1780
I get the same issue when uploading your backup XML file. :(

The issue is caused by your inbound call route on SP1...

You have X_InboundCallRoute set as: {(x.):pk(tovm)},{aa3},{ph1,ph2}

Inbound calls fail to ring ph1 and ph2 with this config, changing the X_InboundCallRoute to {ph1,ph2} then saving and rebooting the device solves the issue. What rules if any do you want to apply to the X_InboundCallRoute on SP1?
User avatar
By WelshPaul
#1782
Any changes you make to the local web based GUI will get overwritten within minutes by the OBiTALK portal. You need to log in to your OBiTALK account and click on the OBi202 > OBi Expert Configuration > Enter OBi Expert.

Then in the left pane click on Voice Service > SP1 Service and then find the X_InboundCallRoute. You need to remove the tick from the OBiTALK Settings Check-box and put a tick in the Device Default Check-box.

Like so:
Screenshot (378).png
OBi202 OBi Expert
Screenshot (378).png (33.03 KiB) Viewed 732 times
Then save the changes, wait several minutes for the OBiTALK portal to push the new configuration changes to the device. That will fix the issue, then if you wish you can log back into the portal and navigate back to SP1 > X_InboundCallRoute and remove the tick from the Device Default Check-box and put it back in the OBiTALK Settings Check-box and once again save the configuration changes.

The reason for this is probably at some point you made a change to the SP1 > X_InboundCallRoute parameter by removing the tick from the OBiTALK Settings Check-box and entering {(x.):pk(tovm)},{aa3},{ph1,ph2} in place of ph,ph2. When you click back on the OBiTALK Settings Check-box at a later date the portal shows it as being back at it's default value however it doesn't actually make the change on the device. (I found out the hard way, as you now have.)

That's why I asked you to log in locally to the the OBi202 and check the X_InboundCallRoute manually to make sure it was in fact it's default value. :)
User avatar
By WelshPaul
#1784
Are you trying to use the auto attendant feature at all?

If not then replace it in the same manner you did for SP1.
User avatar
By WelshPaul
#1786
symphony63 wrote:I'm sorry to tell you it didn't work. It still shows {(x.):pk(tovm)},{aa3},ph,ph2. :( :-/
And the inbound calls don't go through.
WOW Really?

Do you currently have the tick in the Device Default Check-box? or is it back in the OBiTALK Settings Check-box?

I suspect you have now put it back in the OBiTALK Settings Check-box. Am I correct?

Have you ever imported a backup through the OBiTALK portal?
User avatar
By WelshPaul
#1788
Sounds like the portal hasn't pushed the new configuration to your device yet.

Try removing both ticks and insert {ph1,ph2} in place of ph,ph2 and save the changes. Your device should reboot shortly and update. Enter it's IP address into your browser and check the local GUI and confirm it has indeed updated.

Also put a tick in the Default box in the local GUI, save and reboot. See if that helps! :-/

If not the only thing you can do is delete the device from the OBiTALK portal and before you re-add the device reset your OBi202 by picking up the handset and dial ***8

Once your OBi202 has rebooted, re-add it to your OBiTALK account.

If this does't work I will drop Mark an email because something clearly isn't right here and should be able to take a deeper look at your OBiTALK account.
User avatar
By WelshPaul
#1790
symphony63 wrote:I think I'm just resetting the device.
After reset can I log into GUI and configure from there? Then re-add to OBiTALK and not lose any of the config
No, you must pick which method you want to use to configure your device and then only use that method. If you configure locally then add it to the OBiTALK portal it will probably wipe your local settings, same when you delete it. Well that is what happened to me when I used the portal previously. (I had no backup, that's why I remember so vividly lol)

You can always restore from a backup but you will need to manually edit the XML file first and remove/replace that troublesome inbound call route first.

I have edited the backup file you sent me and set the inbound call routes to SP1 - SP4 to their default values. Try restoring it.
Attachments
(10.62 KiB) Downloaded 46 times
User avatar
By WelshPaul
#1792
I configure all my devices locally and if I want remote access I will use port forwarding.

That's my personal preference though... I attached an slightly modified version of your backup to my previous post.
User avatar
By WelshPaul
#1793
I just had a thought when drinking my coffee... When I told you to factory reset the device way back in the thread and remove it from the OBiTALK portal then re-add it... You did do this right?

If you just factory reset the OBi202 and didn't then proceed to remove it from the OBiTALK portal and re-add it then it will no longer be communicating with your existing OBiTALK account and that is the reason why any changes your making are not getting pushed to the device.

Just a thought.

Advertisement

By Sponsor

Just found out that the latest firmware build for …

Supported Products: OBi504vs OBi508vs Firm…

Supported Products: OBi200 OBi202 OBi300 OB…

These are unlocked and unbranded Snom 760 IP Phone…