VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
By mouse
#2790
Hi Welsh Paul

Thank you very much for these files.

Do they now include the Obiline settings, or should I apply that file on top of these settings?

Also in addition to the values you set, on a working SPA3102 I think I had specific UK values for:
- Ring Frequency
- Ring volts
- Ring wave form
- On hook speed
- Line in use voltage
- Detect long silence/sensitivity
and maybe the equivalent of Tx/Rx gains, though that may have been personal preference. Indeed some of the above may have been set for reasons other than regional adaptation, so please forgive if I am wrong.

I think you do set disconnect tone pattern, but my value was different.

Just an observation, I may have had things set wrong.....

Many thanks

Mike
User avatar
By WelshPaul
#2791
Hi Mike,
mouse wrote:Do they now include the Obiline settings, or should I apply that file on top of these settings?
They have always included the necessary UK OBiLINE settings. You need to connect the OBiLINE to your OBi prior to uploading the XML file, connecting an OBiLINE after uploading the XML file will result in it using the default US configuration.

If you uploaded the XML file to your device and then connected an OBiLINE at a later date just upload the XML file again.
mouse wrote:Also in addition to the values you set, on a working SPA 3102 I think I had specific UK values for:
- Ring Frequency
- Ring volts
- Ring wave form
- On hook speed
- Line in use voltage
- Detect long silence/sensitivity
and maybe the equivalent of Tx/Rx gains, though that may have been personal preference. Indeed some of the above may have been set for reasons other than regional adaptation, so please forgive if I am wrong.

I think you do set disconnect tone pattern, but my value was different.

Just an observation, I may have had things set wrong.....

Many thanks

Mike
Again the above XML files include the above parameters and more, Tx/Rx gains are however not altered as these usually do not require modification. :)
By mouse
#2792
OK my Obi shows the above settings set at defaults. So something must have gone wrong as you say. If you disconnect and reconnect the Obiline must you re-apply the settings?

Just to confirm, to load all the settings I just load the one xml file right, the one attached to this post, and that does for the whole device plus the Obiline?

If so that's nice and easy, thanks.
User avatar
By WelshPaul
#2793
mouse wrote:OK my Obi shows the above settings set at defaults. So something must have gone wrong as you say. If you disconnect and reconnect the Obiline must you re-apply the settings?

Just to confirm, to load all the settings I just load the one xml file right, the one attached to this post, and that does for the whole device plus the Obiline?

If so that's nice and easy, thanks.
How are you configuring the device? locally or via the OBiTALK portal?

If your configuring the device via the portal and uploading the XML file locally then any changes made via the XML file will get overwritten by the OBItalk portal.

I'm not sure why OBIHAI have setup the OBi2xx series to hide the OBiLINE setting when no OBiLINE is connected, after all the OBiWIFI and OBiBT settings are available even when neither are connected to the device. (i did mention this to Mark over at OBIHAI previously)

Anyway... No you do not lose the settings if you remove the OBiLINE and re-connect it after uploading the settings. The only requirement is that the OBiLINE be connected to your OBi2xx at the time you initially upload the XML file.
mouse wrote:Just to confirm, to load all the settings I just load the one xml file right, the one attached to this post, and that does for the whole device plus the Obiline?.
In one word Yes! :P
By mouse
#2794
OK no, I found out quickly that the server autoprovisioned by default, so I turned off autoprovisioning from Obitalk.

Sorry to ask for clarification - my original query was a bit ambiguous on re-reading.

OK so I can sort this out now thanks to you......

Mike
User avatar
By WelshPaul
#2796
mouse wrote:That sorted the problem I think. I could not get a reliable ring thru or answer previously. Thanks very much for your help. Must have over-written some of your settings as some point probably before I discovered autoprovisioning.....
No problem, glad you got it sorted. :)
By FOX_OFF
#3906
Hi,

I'm new here and to VOIP stuff.. So sorry if this has been covered before. I have spent a couple of days looking through these forums and have seen that there is/was an issue with uploading configured XML files using the ObiTalk Portal? I am trying to configure my OBi200 device to use UK settings, however when I try to upload via the ObiTalk portal, it says its succesfully imported but does not update any settings.
If I try to update the config via the devices local webpage, it works a bit better by updating most of the settings (although the changes still dont update in the web portal), however did make the performance of my phone worse. I.e. No longer had caller ID for example. I was then told by ObiTalk Support not to use the local device webpage.

Out of the box it seems to work fine but I thought it would be best to apply UK settings. So any advice on this would be much appreciated.

Also I am not sure if this is relevant but I am unable to pass Caller ID names through to my phone. The Number shows up fine, just not the Name even though I have imported my Google contacts into the ObiTalk portal.. any ideas on this too? Or does my phone just not support it. (Gigaset A120 X2 Cordless Telephone)
User avatar
By WelshPaul
#3907
Pick either the OBiTALK portal configuration or local configuration, don't try to configure your device using both methods as the OBiTALK will always overwrite any local configuration that's different to what's configured by OBiTALK.

How would you prefer to configure your device, via OBiTALK or locally? As for the caller display not working:

There is a setting called "CallerIDTrigger" and the correct UK setting for this is"Before First Ring", I have noticed though that this sometimes stops caller ID working (not sure if it's a firmware issue or not) so try manually changing this to "After First Ring".

This setting can be found by navigating to PHONE1 Port > Port Settings
By FOX_OFF
#3908
Thanks for the quick reply. I will just stick to the ObiTalk portal from now on then.
I have just noticed in the portal loads of red exclamation points next to a lot of settings. It looks like those are the settings wanting to be changed by your XML config file. I just need to untick 'ObiTalk settings' and it seems to update the changes to the UK settings.

Thanks for your help on this. I will give it a try tonight with the Caller ID. Do I need to pay for the ObiExtras to get Caller ID working properly?
User avatar
By WelshPaul
#3909
Before proceeding I recommend you remove your device from the OBitalk portal and factory reset it. Once done, re-register the device against your OBiTALK account.

To import the UK XML file to your OBiTALK account you need to do the following:
  1. Log in to your obitalk account.
  2. Select the OBihai device you wish to configure by clicking on it's name under "My OBi Devices".
  3. Scroll down and click on the "OBi Expert Configuration" button.
  4. Under the "Manage Expert Configuration" section click on "Choose File" located next to the text "Saved Configuration File" and select the UK XML file.
  5. Click on the "Import Config to OBi Expert" button.
The following message will appear on the top of the webpage "The specified configuration has been imported successfully.", You now need to click on the "Enter OBi Expert" button to enter the OBi Expert Configuration pages.

Inside the OBi Expert Configuration pages, you will notice its resemblance to the OBi device web page menu, look and layout. To the right of the configurable parameter value field, there may be a red exclamation mark (!). When this mark is present, it means the parameter value next to where it appears has an OBi Expert configuration database entry that is different than the OBiTALK database entry. If the Device Default and OBiTALK boxes are left unchecked, then the OBi will use this setting in its active configuration.

Make sure you remove the ticks from both check boxes next to every parameter that has the red exclamation mark (!).

For future reference, if you decide to configure locally, all you need to do is upload the XML file by entering the IP address of your OBi in your browser and navigate to System Management > Device Update > Restore Configuration. Your OBi device will reboot and that's it.
FOX_OFF wrote:Do I need to pay for the ObiExtras to get Caller ID working properly?
Nope :)
User avatar
By WelshPaul
#3910
FOX_OFF wrote:Also I am not sure if this is relevant but I am unable to pass Caller ID names through to my phone. The Number shows up fine, just not the Name even though I have imported my Google contacts into the ObiTalk portal.. any ideas on this too? Or does my phone just not support it. (Gigaset A120 X2 Cordless Telephone)
Actually I think you will need the OBiEXTRA's if you want your Google Contacts Name and Number passed to the phone.
Caller ID Name with Number

When you integrate Google Contacts with your OBi device, incoming calls from people in your Google Contacts directory will show their name and number on your phone’s display.
I have never used the service myself, or Google Contacts. I simply save my contacts on the phones themselves, inbound caller ID is automatically matched against a saved contact and as such their name and number is then displayed.
By FOX_OFF
#3911
Yes I think I will just do it the old fashioned way as I had signed up to the free ObiEXTRAS trial but Caller ID still did not work.. Not to worry, its just a bit of a pain entering in all the names and numbers on multiple handsets around the house.

Thanks for all your advice.
User avatar
By WelshPaul
#3913
I can't even sign up for OBiEXTRA's as I get the following error:
Invalid Request
Error Message:
Input parameter amount is too low (Minimum amount is USD 0.06)
transparenttransparentFor further information on error codes please see the Integration Guide.
Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests

Landline bridge advice

Factory reset your OBi after updating it's firmwar…

Yep, good phones too! The Cisco SPA phones are na…

Hi Phil, Thanks for coming back to us and confirm…

Grandstream GXP1610 IP Phone

Description - Grandstream GXP 1610 IP Phone HD w…