VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
By ANTHONY2201
#2859
Hi I have an issue with my setup that Ive done following your article for some reason my ip phone works fine for a day or so then when i try and make outbound call on it later on it just says busy and gives a busy tone but it still works fine for incoming calls I have 2 lines from 1 obi202 box connected to it via sp2 and sp4 where sp1 and sp3 are where i have Google voice connected do you have any idea what might be going on the IP phone I'm using is a spa525g2 i think the issue may be a setting on the phone since i restored the obi202 with a backup file i made and it didn't fix the issue originally but then when i factory reset the phone and put in the settings into it again it worked fine for like a day or 2 i cant be 100% sure on when the issue of not being able to place outbound calls starts as i do not sit at phone and constantly make outbound calls

the IP phone is a Cisco SPA525G2 and it is connected via Ethernet as well as the obi202 is connected via Ethernet as well
User avatar
By WelshPaul
#2861
Hi Anthony,

We need a little more information...

Do you have SIP ALG disabled on your router?
Are you using the OBiPLUS "light" or "premium" service?
Are both devices running the latest firmware?
What does the call history show on your OBi202 when you attempt to make a call and hear the busy tone?
What is the registration status of the SP slots? (See: System Status Page)
Is your OBi202 before or after your router? Same goes for the SPA525G2?
Can you grab a syslog of your OBi202 while the issue is present and post that here also?

Are you able to make a test call over OBiTALK? Try dialing **9 222 222 222 when the issue pops up again. Of course this could always be a Google Voice issue - Can you setup a SIP based VoIP provider on one of the SP slots for the time being? When the issue pops up again, try and place a call over the SIP based VoIP provider you setup temporary.
By ANTHONY2201
#2885
I dont see an option for sip alg on my router I am using a modem router combo motorola SBG6580 i am not subscribed to obiplus yes both devices are using the latest firmware there is no call registered on the obi when i attempt to place an outbound call with the ip phone i have attached a screen capture of the registration status of the sp slots both items are after my router since im using a combo unit te ip phone is able to receive incoming calls without any issue its just outbound call wont go through on it while they go out fine on analog phones the ip phone says invalid number on screen when i try and place a test call over obitalk
Attachments
obi status.jpg
obi registration status
By ANTHONY2201
#2886
I just preformed a full factory reset of the ip phone by tapping the speaker button while it was booting up thus erasing all settings that have been put into it and then set it back up and its working fine again i have not made and changes to the obi202 i think its an issue with a setting on the ip phone but i'm not sure where
User avatar
By WelshPaul
#2888
ANTHONY2201 wrote:I dont see an option for sip alg on my router
The issue you describe Is often due to a router's firewall (also known as NAT) blocking certain operations of the VoIP telephone adapter.

From the Advanced tab > select the Options sub-link. The Advanced - Options page appears.
On the Advanced - Options page, NAT ALG Status section:
a. SIP - UnCheck Enable.
b. Click the Apply button
User avatar
By WelshPaul
#2889
ANTHONY2201 wrote:I just preformed a full factory reset of the ip phone by tapping the speaker button while it was booting up thus erasing all settings that have been put into it and then set it back up and its working fine again i have not made and changes to the obi202 i think its an issue with a setting on the ip phone but i'm not sure where
Does it work once again if you simply power cycle only the phone?
By ANTHONY2201
#2891
it does not work if i simply power cycle the phone I have left in unplugged or a few minutes previously as well as unplugged the obi202 and plugged the obi202 back in then plugged the phone back in and the phone still wouldn't dial out but could receive incoming calls i have also power cycled only the IP phone and it still does the same thing I have done what you suggested as to uncheck sip and click apply on my router the spa525 is plugged directly into router/modem as well as is the obi
User avatar
By WelshPaul
#2892
Ok I just setup a test environment. Only difference is I am using an OBi1032 instead of a Cisco SPA525G2...

So far everything appears to work fine, I will leave it setup and see if it fails to dial out in due course. In the meantime this is what I have:

OBi202 factory reset and it has an IP of 192.168.1.215
OBi1032 has an IP of 192.168.1.5

Both devices are connected to my routers lan port...

On my OBi202 I am using ITSP Profile A and SP1 -

ITSP Profile A Settings:
ITSP Profile A/General/SignalingProtocol = SIP (default)
ITSP Profile A/SIP/ProxyServer = 192.168.1.5 (ie IP address of our OBi1032 IP Phone)
ITSP Profile A/SIP/ProxyServerPort = 5060 (default)
ITSP Profile A/SIP/X_SpoofCallerID = Enabled (tick)

SP1 Service Settings:
SP1/X_ServProvProfile= A (We’re saying use the ITSP A profile with this voice service)
SP1/X_UserAgentPort = 5060 (default)
SP1/X_RingProfile = A
SP1/X_RegisterEnable = Disabled (remove tick)
SP1/AuthUserName = 1001
SP1/AuthPassword = 1234567890
SP1/X_Proxy = Enabled (tick)

Now on my OBi1032 I have used:
Proxy = 192.168.1.215:5060 (ie: IP address of OBi202 and the port as used on the OBi202)
User ID = 1001
Password = 1234567890
Register Expires = 60
Register = yes
Send Resp To Src Port = yes

I don't have any VoIP/SIP providers setup on my OBi202 so I am using the OBiTALK service to test. So I have entered: {1001>(Msp1):pp} in the X_InboundCallRoute under SP1. This means any calls I place out over my OBi1032 go out over my OBi202's OBiTALK service.

Then under 'OBiTALK Service' on my OBi202 I have set the InboundCallRoute parameter to: {SP1(1001@local_client),ph,ph2} so that when anyone calls my OBi202's OBiTALK number my OBi1032 IP phone rings.

Everything works as it should, is this how you have your configured?

EDIT: Make sure both OBi202 and SPA525G2 have static IP addresses. I have in the past experienced registration issues when DHCP expires and the lease is renewed. :)
By ANTHONY2201
#2893
yes some what except for i have 2 number setup on obi202 and they both connect to the ip phone ip phone is able to recieve calls even when it cant dial out after resetting ip phone when it starts having issues and reprogramming it it works perfect i have 1 line on obi202 that rings ip phone and analog phones the second line only rings the ip phone this is the inbound call route i used for that to work {SP4(1002@local_client)}
User avatar
By WelshPaul
#2894
Lets see if disabling SIP ALG makes a difference, I will leave my test setup as is for now and see if I encounter any issue with outgoing calls.

It wouldn't be an issue with the inbound call routes as everything works for the best part of a day or so... If it does happen again, reboot the OBi202 and do nothing with the Cisco. Once the OBi202 reboots try making a call.
By ANTHONY2201
#2966
OK phone is still working fine so i think that fixed it but i am unable to dial obi numbers from ip phone suck as **9xxxxxxxxx the IP phone just registers as busy Ive edited the dial plan on the IP phone to (**xxxxxxxxxxxxxxx|[3469]11|0|00|[2-9]xxxxxx|1xxx[2-9]xxxxxxS0|xxxxxxxxxxxx.) what would be the correct dial plan to use with obi202
User avatar
By WelshPaul
#2968
I'm going by memory here... You need to add {1001>(<**9:>(Mpp)):pp} to the Voice Services > SPX Service > X_InboundCallRoute = {1001>(Msp1):SP1} syntax on your OBi2xx device.

It should look like this: {1001>(Msp1):SP1},{1001>(<**9:>(Mpp)):pp}

On your Cisco add **9xxxxxxxxx to it's dial plan. Once done try dialing **9222222222, this should connect you to the OBi echo test server.
By ANTHONY2201
#3464
ok that fixed the issue I was having in my current setup I have sp1 with a google number sp2 linking first google number to ip phone then sp3 with a google number and sp4 linking the second google number to the ip phone is it possible to link both numbers to the ip phone with only one sp this way I can add another line without getting another obi also I am trying to get music on hold working I am using music@iptel.org I have a line setup on the ip phone with ipkall and getonsip so I can receive inbound calls on that line music on hold works fine but for the 2 google lines its just silence when put on hold I can dial out to music@iptel.org with either of the google lines and it connects and plays just fine when I dial out to the music on hold service from the ip phone with google numbers connected through obi what can I do to accomplish this
Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests

Landline bridge advice

Factory reset your OBi after updating it's firmwar…

Yep, good phones too! The Cisco SPA phones are na…

Hi Phil, Thanks for coming back to us and confirm…

Grandstream GXP1610 IP Phone

Description - Grandstream GXP 1610 IP Phone HD w…