VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.

Advertisement

By Sponsor
User avatar
By WelshPaul
#3020
Anyone else unable to log into their OBi device using Microsoft Edge? :sweat:

I get the popup asking me to enter my username and password but when I submit the correct credentials all I get is the pop again asking me for my username and password? After three attempts to login I get the dreaded 401 Unauthorized! page.

I can log in to my Snom 870 which uses the same popup windows using using Microsoft Edge, again I can log in to my Yealink T48G although this uses the phone's built in GUI to display the username and password fields...

Looks like the OBi web based GUI is not fully accessible on both Google Chrome and Microsoft Edge browsers.

Advertisement

By Sponsor
User avatar
By WelshPaul
#3021
The problem appears to be present on all OBi devices. I took a factory reset OBi110 and hooked it up to my network and again I am unable to login to the device using the devices default username and password of admin/admin.
obi_edge.png
OBi110 login page using Microsoft Edge browser
obi_edge.png (48.65 KiB) Viewed 1632 times
Three attempts gets you this page:
obi_edge_401.png
OBi110 401 Unauthorized!
obi_edge_401.png (35.92 KiB) Viewed 1632 times
By gsmlnx
#3032
Isn't this just another manifestation of the issue with Chrome in that all the Obi's use iframes in JavaScript and the new browsers have implemented security measures to stop phishing attacks via iframe vulnerabilities.

Firefox is still usable but it will need a Obi update of their web interface to fix the issue. TheJavaScript iframe has always been a security risk and should never be used.
User avatar
By WelshPaul
#3071
Maybe, looks like chrome has a fix in place: Issue 512827: xsl fails to load properly in iframe

We just have to wait for the stable release to be updated.
User avatar
By WelshPaul
#3147
Chrome has released (44.0.2403.155) a new update and once again we can configure our Obihai devices. :-D

Still unable to login to any OBihai devices using Microsofts Edge browser! Hopefully this will be fixed in an upcoming release.

Advertisement

By Sponsor

Just found out that the latest firmware build for …

Supported Products: OBi504vs OBi508vs Firm…

Supported Products: OBi200 OBi202 OBi300 OB…

These are unlocked and unbranded Snom 760 IP Phone…