VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.

Advertisement

By Sponsor
By billybob
#3300
Hi Paul

Received my Obi110 this morning thank you :-D :-D :-D
Thanks for changing the settings from US to UK :-D :-D :-D

Dial # no service configure error?????? :beaten:

Echo test is fine

Setup a free Sipsate account with free incoming number no credit for outgoing calls. The problem, When you ring the incoming number the phone rings but when I answer, the incoming phone stops ringing and there is no sound. The phone making the call is still ringing so is not connecting. The call log on the Obi110 call status says the call was connected?

Call 1 09/05/2015 12:35:01
Terminal ID SP1 PHONE1
Peer Name
Peer Number
Direction Inbound Inbound
12:35:01 Ringing
12:35:06 Call Connected
12:35:11 End Call
Call 2 09/05/2015 12:32:02
Terminal ID SP1 PHONE1
Peer Name
Peer Number
Direction Inbound Inbound
12:32:02 Ringing
12:32:06 Call Connected
12:32:12 End Call
Call 3 09/05/2015 12:21:26
Terminal ID SP1 PHONE1
Peer Name
Peer Number
Direction Inbound Inbound
12:21:26 Ringing
12:21:30 Call Connected
12:21:37 End Call

Advertisement

By Sponsor
User avatar
By WelshPaul
#3308
Great news...

The OBi110 uses the PSTN (FXO) as the primary line by default. Is your OBi connected to a PSTN line? As it is now, any calls you make should be sent out over the line port (FXO) by default unless you use a prefix of **1 or **2.

If you have not connected the OBi110 to a working PSTN line then you can change the primary line to SP1 or SP2 by navigating to: Physical Interfaces > PHONE Port > PrimaryLine and selecting the service of your choice.

As for Sipgate, sounds like it hasn't been configured correctly or maybe down to a NAT issue. Do you have SIP ALG disabled on your router? I noticed in the log above that SP1 is being used for the call? I configured SP1 for use with VoIP2GO? Are you trying to use the VoIP2Go service? You need to email Steve and get the account activated first.
By billybob
#3309
Hi Paul
Primary line is set to SP1. Also I changed SP1 to Sipgate. In the ITSP Profile A the OutboundProxy should be proxy.live.sipgate.co.uk but it keeps reverting to sipgate.co.uk.
SIP ALG is disabled

Steve did say in one of his posts he can set the box up remotely? With Voip2Go as the outbound calls. With sipgate’s free number for the inbound calls for testing.
User avatar
By WelshPaul
#3310
Ok no worries...

What does the registration status on the your OBi110 say under Status > System Status > SP1 Service Status? It should say something like: Status Registered (server=217.10.79.23:5060; expire in 48s) help

I take it you didn't factory reset the unit? Just altered the registration for SP1?

Service Providers > ITSP Profile A
ProxyServer: sipgate.co.uk
RegistrarServer: sipgate.co.uk
OutboundProxy: proxy.live.sipgate.co.uk
RegisterExpires: 600

Voice Services > SP1 Service
AuthUserName: SIP-ID
AuthPassword: Password

If you didn't factory reset the unit, some additional parameters were changed for use with the Voip2Go service which may have an impact on the Sipgate service. Change them back to their defaults:

Service Providers > ITSP Profile A
X_ProxyServerRedundancy: Disable by removing tick
X_DnsSrvAutoPrefix: Disable by removing tick
X_UserAgentName: OBIHAI/${DM}-${FWV}

Just setup an OBi110 using the above and it worked just fine this end. :)

To test your phone"s configuration, please dial the following sipgate numbers:
10000
10005
10020

What you can do if it still isn't working for you is factory reset your OBi110 (if you haven't already) and then upload the
OBIHAI OBI1XX UK XML CONFIGURATION FILES V2.5 **UPDATED 21 JUL 2015** file and proceed to setup sipgate as instructed above.

You can also try using a STUN Server in the settings of your OBi110.

Service Providers > ITSP Profile A > General
STUNEnable: Enabled
STUNServer: stun.sipgate.net
X_STUNServerPort: 3478

The STUN Protocol is intended to help devices communicate from behind a router's NAT. STUN will not work correctly with all NAT setups, and in some cases STUN may resolve some issues only to lead to others.
By billybob
#3311
Hi Paul
You ARE the man I didn’t do a factory reset before. I just did then loaded the XML file, set up Sipgate and it’s WORKING on incoming calls
Tests 10000 OK. 10005 OK. 10020 OK

Now does it matter that when dialling # I still get a No service configured error?
Also the outbound Proxy keeps reverting to sipgate.co.uk from proxy.live.sipgate.co.uk? It works so I take it this doesn't matter?
Do I need to change the UK Regional Settings for OBihai Devices?
Can I backup my settings so if I mess something up in the future, I can reload the working settings
Many thanks for your help I an one very happy camper :-D
User avatar
By WelshPaul
#3312
billybob wrote:Now does it matter that when dialling # I still get a No service configured error?
Is the Line port on your OBi110 connected to a working PSTN line?

OBi 110 users can hit # to immediately connect to the PSTN and get outside dial tone. Obviously you need your OBi110 connected to a working landline for this to work.
billybob wrote:Also the outbound Proxy keeps reverting to sipgate.co.uk from proxy.live.sipgate.co.uk? It works so I take it this doesn't matter?
The reason why it works is likely down to the fact you don't need to use the outbound proxy. It should not be reverting from proxy.live.sipgate.co.uk to sipgate.co.uk.

How are you configuring your device? locally or via the obitalk portal? I suspect that you have tried to configure the device via the portal at some point and as a result anything you enter locally is getting overwritten by the settings still held in the portal.

Try setting the following - System Management > Auto Provisioning > OBiTalk Provisioning > Method: Disabled

Now log in locally to your OBi110 and change the OutboundProxy back to proxy.live.sipgate.co.uk
billybob wrote:Do I need to change the UK Regional Settings for OBihai Devices?
Nope
billybob wrote:Can I backup my settings so if I mess something up in the future, I can reload the working settings
Many thanks for your help I an one very happy camper :-D
Yes, System Management > Device Update > Backup Configuration

This will backup everything but your passwords. Once you restore the file all you need to do is enter the passwords for your SIP accounts. :)
By billybob
#3313
No not connecting a PSTN line yet

Try setting the following - System Management > Auto Provisioning > OBiTalk Provisioning > Method: Disabled That sorted it

Now log in locally to your OBi110 and change the OutboundProxy back to proxy.live.sipgate.co.uk It worked


billybob wrote:
Do I need to change the UK Regional Settings for OBihai Devices?”
Nope Thank you

Yes, System Management > Device Update > Backup Configuration

This will backup everything but your passwords. Once you restore the file all you need to do is enter the passwords for your SIP accounts. :)

Which boxes do I tick?
Choose Backup Options Incl. Running Status Incl. Default Value Use OBi Version :oops:

Thanks for your help it is really appreciated. you are a VoIP :ninja:
User avatar
By WelshPaul
#3314
billybob wrote:Which boxes do I tick?
Choose Backup Options Incl. Running Status Incl. Default Value Use OBi Version :oops:
No need to tick any of the boxes, just click on backup. :P
User avatar
By WelshPaul
#3316
No problem, all part of the fun. :)

Don't be afraid to play and tweak your device. You will have it mastered in no time. :P

Advertisement

By Sponsor

Just found out that the latest firmware build for …

Supported Products: OBi504vs OBi508vs Firm…

Supported Products: OBi200 OBi202 OBi300 OB…

These are unlocked and unbranded Snom 760 IP Phone…