VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
User avatar
By mr_mf
#4237
Hi there,

I am using an OBi110 with FreePBX doing all the clever routing over the PSTN line. Everything works fine but I get a horrible echo when making calls over PSTN.

For example if I dial 1471 and talk then I can hear my own voice. I have read that this can be due to impedance problems - I am using 370 + (620 || 310nF) which I think is correct for the UK. I have also experimented by changing the Line ChannelTxGain down to -7 which makes the problem better but some callers then report that it is difficult to hear me.

Does anyone know how to fix this ?

Thanks for your help.

Mike
User avatar
By WelshPaul
#4238
Hi,

I'm surprised to hear that you're having problems with echo on PSTN calls made over your OBi110, 370 + (620 || 310nF) is indeed the correct setting for the UK. Have you upload the UK XML Configuration file found here to your OBi110? If not, can you do so please.

If you have and the echo is still present, before I recommend making any changes to your OBi110, can you confirm that you have connected a telephone to the phone port on the OBi110 and that the echo is still present? I just want to rule out FreePBX.
User avatar
By mr_mf
#4239
WelshPaul,

Thanks for your response. I have uploaded the file and also manually checked the settings - they all look ok.

I modified the Phone Port DigitMap, OutboundCallRoute and PrimaryLine to force the Phone Port to connect to the PSTN line and cut out FreePBX from the call. The result is the echo is a lot better - you can still detect it but only just. When I route the Phone to FreePBX and out again on the Line then the echo gets a lot worse.

So it's obviously partly FreePBX causing the problem. Do you have any ideas what could be causing the issue on FreePBX - it's running on a Raspberry PI 3 and the load average is 0.00 so it really shouldn't be having issues.

Thanks

Mike
User avatar
By mpmc
#4241
I went and double checked my settings for impedance & had it set at 270(+750) for both line & phone! I can't be 100% sure why I did that but I think it had something to do with the echo / volume fluctuation i experienced using the exact same setup. See viewtopic.php?f=10&t=275. I've changed them back to the recommended settings, hopefully I won't suffer any echo like before, but time will tell :smiling_imp:

- I've since replaced the RPi B with a Banana Pi though which is much faster!

@WelshPaul Why have an emoji for faecal matter only for it to get "bleeped" out? :confused:
User avatar
By WelshPaul
#4242
mr_mf wrote:WelshPaul,

Thanks for your response. I have uploaded the file and also manually checked the settings - they all look ok.

I modified the Phone Port DigitMap, OutboundCallRoute and PrimaryLine to force the Phone Port to connect to the PSTN line and cut out FreePBX from the call. The result is the echo is a lot better - you can still detect it but only just. When I route the Phone to FreePBX and out again on the Line then the echo gets a lot worse.

So it's obviously partly FreePBX causing the problem. Do you have any ideas what could be causing the issue on FreePBX - it's running on a Raspberry PI 3 and the load average is 0.00 so it really shouldn't be having issues.

Thanks

Mike
I strongly suggest that you try and fix any echo that occurs on the OBi110 first, no matter how little it is. Only then would I recommend tweaking FreePBX! So get that phone plugged back into the OBi110 phone port and make some calls via your PSTN line. ;-)

I understand from your OP that you have tried reducing ChannelTxGain down to -7, but try the following again...

Look in Line Port > Port Settings you will find these two parameters:

ChannelTxGain
Gain in dB (-15 to 15) to apply to the signal transmit from the OBi to the PSTN company

ChannelRxGain
Gain in dB (-15 to 15) to apply to the signal received by the OBi from the PSTN company

Adjust these again carefully - a change of 3dB upwards or downwards will double or halve the perceived volume.

NOTE: There are also two similar settings in the Phone Port that allow you to adjust the volume sent to and from the telephone plugged into your OBi110. However, if the volume to and from your SIP callers seems ok, then it is most likely that the adjustment is needed on the Line Port if only PSTN calls are having issues.

Adjusting these settings and testing takes both time and patience, give it a go and see if you can eliminate that echo on the OBi110 completely.

Finally, if the OBi is connected to a 100Mbit port, force it to use 100Mbit Full duplex:
  1. Dial * * * 0
  2. Enter option 27 and press #
  3. Press 1 to set a new value
  4. Enter a value of 1
  5. Press 1 to confirm/save
  6. Hang up
This should make the network transaction from/to OBi better.
mpmc wrote:@WelshPaul Why have an emoji for faecal matter only for it to get "bleeped" out? :confused:
@mpmc Thanks for letting me know about the :poop: emoji being censored out! :laugh:

With other a 1,000 emoji to choose from there was bound to be an issue or two, you should now be able to use it. :P :
Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests

Landline bridge advice

Factory reset your OBi after updating it's firmwar…

Yep, good phones too! The Cisco SPA phones are na…

Hi Phil, Thanks for coming back to us and confirm…

Grandstream GXP1610 IP Phone

Description - Grandstream GXP 1610 IP Phone HD w…