These can be a real hurdle when setting up VoIP, help others by posting your configs, tips and tricks or simply ask others for help if you're stuck.
By Jack Boxer
#3897
I had an Asus RT-N10+ router and my Grandstream HT502 had no trouble connecting to my SIP providers. I recently upgraded to an Asus DSL-N55U modem/router and now my HT502 cannot register with any SIP server. I used a utility to detect if SIP ALG was in use and it was so I disabled it. I verified it was disabled with the same utility that told me it was active. So SIP ALG is disabled on the router but I still cannot get the HT502 to register with any SIP service. I have tried static IP, DMZ, Port Forwarding, changing ports on HT502, etc. No matter what I do the HT502 will not register to a SIP server when connected via this router. The status of the HT502 shows "unknown NAT" and both lines as "Not Registered". I am hoping someone here will know what to do so I can get my SIP service working again.
User avatar
By WelshPaul
#3898
Hi Jack,

Are you running the latest firmware?

If so, do a factory reset and once complete log in to the router via your web browser by entering it's IP address in the URL field and navigate to WAN > NAT Passthrough, disable SIP Passthroug, press Apply.

Reboot the router by disconnecting it from the mains for 30 seconds.

Just to point out that "Unknown NAT" simply means it has been detected but it doesn't behave in a way which can be classified.

Do you have UPnP switched on?
By Jack Boxer
#3900
Thanks for the reply. Disabling SIP Passthrough was one of the first things I did. No, UPnP is not on. After a lot of messing around with settings in the HT502 and router, and creating new extensions for my SIP accounts the SIP lines finally registered. Doing so much and rebooting the router and HT502 so many times I am not sure what finally made it work, but it is working now so I will just leave it alone. :clown:
WelshPaul liked this
User avatar
By WelshPaul
#3901
Glad you finally got it working. :P

I was going to say if the above didn't work that NAT traversal must be enabled on the Grandstream. If the NAT type is unknown, it is recommended to select “Auto”. But as it's now working I recommend you leave it be! :D
By Jack Boxer
#3902
NAT traversal on the Grandstream is set to "Keep Alive" on both SIP lines. :-) I tried STUN at one point but that did not help. There is no Auto setting that I can find on my device. Only No, Keep-Alive, STUN and UPnP. Yes, since it is working now I am not changing anything. :)

Tried NordVPN then ExpressVPN last night but both …

A good write up on SIP ALG: https://www.voicehost…

Thanks very much. Really appreciate it! :-D

Attached below is my latest OBIHAI UK configuratio…