Get help with installing, upgrading and running a PBX such as Asterisk.
User avatar
By jadreng
#4356
Hi All

I purchased a small PBX by Zycoo ZX20 (for a home deployment) i am trying to configure the BT PSTN line on one of the FXO ports.

http://www.voipon.co.uk/zycoo-zx20a202- ... -4448.html

I am unable to call out or receive calls basically it does not work. The FXO port shows the LED on Red and on the GUI in green. So i am guessing that it is seeing the line, its just something to do with the configuration. Perhaps number pattern, etc.

Any help / experience someone has will be greatly appreciated.

Thanks
Sponsored
User avatar
By WelshPaul
#4358
I'm not familiar with these devices or their GUI but the instruction manual indicates that if port1 or port2 shows a Red LED then it is using a FXO channel, A Green Led indicates a FXS channel. So it is connected and seeing the BT PSTN line. Having briefly read the manual...

3.3 Outbound Call > 3.3.1 Trunks:
  • If you want to set up outbound call to connect to PSTN(Public Switch Telephone Network)
    or VoIP provider, please configure on this page: 【Basic】->【Trunks】
Have you created an analog trunk as per the manual instructions? Make sure that you have a tick in the box next to either analog port #1(1) or analog port #2(2) depending on which port is connected to your BT phone line, like so:
Zycoo_ZX20_trunk.png
You also need to setup both an outbound and inbound route, have you done this?

3.3 Outbound Call > 3.3.4 Outbound Routes:
  • Outbound Routes is to define what trunk is used for outbound call by extension user. If you don't allow extension user call out, please ignore this part.
    Please configure on this page: 【Basic】->【Outbound Routes】
I would recomend that you configure the outbound route as follows:
  • Rule Name: BT PSTN
    Pin Set: Disabled, remove tick.
    Place call through: BT PSTN Line
    Dialing Rules > Define a custom pattern: X.
Any number beginning with 0 to 9 should now be routed out over your BT PSTN line.

3.4 Inbound Call > 3.4.1 Inbound Routes:
  • When a call from outside, you want to forward this call to an extension or IVR, this Chapter will introduce you how to deal with the inbound calls.
    Please configure on this page:【Inbound Routes】

    General
    When a call from a trunk (Analog/ VoIP), it could be forwarded to an extension, call queue, conference or IVR. You can choose based on your requirement.

    Analog Channel DID
    If you want to direct the inbound call from a trunk (Analog) to a specified extension, call queue, conference or IVR, please configure on this page:【Add Analog Channel】
So what it's telling you here is that you need to navigate to Inbound Routes > Analog DIDs and click Add Analog Channel. Here you need to create an inbound route like so:
Zycoo_ZX20_add_analog_channel.png
Channel: Choose Analog Port of trunk E.g. Analog Port #1(1)
Associated Extension: Select Extension, call queue, conference or IVR for DID.

Obviously you need to have previously setup an extension, call queue, conference or IVR. Without one, there is nowhere to route a call to.

User manual: http://zycoo.com/files/upload/ZX20_User_Manual.pdf
User avatar
By jadreng
#4359
Hi thanks for the reply

Any ideas on these settings , they are under Advanced Settings on the Trunk Port

Input Volume
Output Volume
Answeronplarityswitch
Hanguponplarityswitch


Also on Global Analog Settings Caller ID Detect and General Tab.

There is Echo Training, Busy Count, etc...

Thanks
User avatar
By WelshPaul
#4360
jadreng wrote:Hi thanks for the reply

Any ideas on these settings , they are under Advanced Settings on the Trunk Port

Input Volume
Output Volume
Answeronplarityswitch
Hanguponplarityswitch


Also on Global Analog Settings Caller ID Detect and General Tab.

There is Echo Training, Busy Count, etc...

Thanks
I'm confused, did my previous post resolve your original issue(s)? If it did, what's the purpose of editing the other parameters listed under the advanced settings on the trunk port? If it ain't broke...
User avatar
By WelshPaul
#4362
Not working for outbound, inbound or both? The information in the second post is correct and how you should configure a trunk, outbound and inbound route, al be it basic. If it is not working for you then the problem is else where, extension, phone or NAT related maybe. Anyway, I need more information from you...
  1. What port is your BT line connected to and how exactly is it connected? E.g RJ11 to BT cable, RJ11 connected to port 1 on the ZX20 and the BT plug connected to a microfilter which in turn is connected to my BT master socket.
  2. What exactly is displayed under "Channels" on your ZX20's "Info Page" once it's connected to your BT line? Post a screenshot if possible.
  3. What phone are you using to make and receive calls and has it registered to an extension successfully?
  4. Is your ZX20 running the very latest firmware / software?
Finally, take a look at the extension settings that the phone is registered against, what does it next to "Analog Phone" and "Dial Plan"? What options do you have when clicking on the "Dial Plan" drop down box?
User avatar
By jadreng
#4363
Hi

Please see image with for Channel status.

Regarding your question:

What port is your BT line connected to and how exactly is it connected? E.g RJ11 to BT cable, RJ11 connected to port 1 on the ZX20 and the BT plug connected to a microfilter which in turn is connected to my BT master socket.

Its connected from a centralised splitter via a BT plug to an RJ11 to the back of the unit (Port 2) I have tried the other port on the unit incase it was faulty. its a 4 wire cable.

The unit is on the latest firmware, extensions are working and can perform internal calls (extension to extension).

Finally i have noticed when i disconnect the RJ11 from the unit i get a phantom call. Also tried incoming call mobile phone to PSTN and it rings on the extension however when i pick up its just dead silence and then ends the call.

Thanks
Attachments
Screen Shot 2017-02-26 at 23.52.41.png
User avatar
By WelshPaul
#4364
The image you posted shows that the BT Line is connected and has been detected OK on Port 2.

Also appears that you have successfully setup a Trunk and inbound route too as the phone rings on an incoming call, however the lack of audio could be NAT or Codec related. Have you disabled SIP ALG on your router?
WelshPaul wrote:
  1. What phone are you using to make and receive calls and has it registered to an extension successfully?
Finally, take a look at the extension settings that the phone is registered against, what does it next to "Analog Phone" and "Dial Plan"? What options do you have when clicking on the "Dial Plan" drop down box?
Can you also answer both the above too please?
User avatar
By jadreng
#4372
WelshPaul wrote:The image you posted shows that the BT Line is connected and has been detected OK on Port 2.

Also appears that you have successfully setup a Trunk and inbound route too as the phone rings on an incoming call, however the lack of audio could be NAT or Codec related. Have you disabled SIP ALG on your router?
WelshPaul wrote:
  1. What phone are you using to make and receive calls and has it registered to an extension successfully?
Finally, take a look at the extension settings that the phone is registered against, what does it next to "Analog Phone" and "Dial Plan"? What options do you have when clicking on the "Dial Plan" drop down box?
Can you also answer both the above too please?
Yes all extensions are registering okay. I am able to make calls from and to internal extensions also able to listen to the caller.

In terms of NAT i have connected the gateway (zycoo) to the laptop and installed a softphone - in hopes of eliminating networking issues.

I have enabled all codec available so i don't think thats an issue.

Finally under Dial Plan i have the only dial plan i created - i believe this is okay... On Analog phones "No Analog lines detected."
Attachments
Screen Shot 2017-03-05 at 00.02.17.png
User avatar
By WelshPaul
#4374
Where did you purchase this from? was it second hand? Maybe the device is faulty. I haven't used one of these myself, this is just an Asterisk box with a custom interface so all you need to do (in theory) is setup a trunk, extension, outbound route, inbound route, and apply a dial plan. Can you factory reset the ZX20 and set it up as instructed here: viewtopic.php?p=4372#p4358

The instructions written in the second post are 100% correct, if your problem still persists then post a screen shot of the custom dial plan GUI.
User avatar
By WelshPaul
#4384
You're dial plan is wrong. Replace _9XX. With X. as instructed in post 2. Also make sure you have the right port selected, in a previous post you were using port 2.

However this wouldn't cause any issues with receiving calls. Let me read through the manual one more time and I will get back to you.
Sponsored
Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests

Supported Products: OBi504vs OBi508vs Firm…

Supported Products: OBi200 OBi202 OBi300 OB…

Enter your email address here: https://haveibeenpw…

Well, with VoiceHost you can! I needed to report …