Get help with installing, upgrading and running a PBX such as Asterisk.

Advertisement

By Sponsor
User avatar
By WelshPaul
#64
Many people struggle when initially trying to use Sipgate on their Asterisk system - especially when going through a NAT firewall.

The key to getting the system to work reliably without getting one way transmission problems is to allocate ports for each Sipgate trunk. On my PBX I have 4 standard Sipgate numbers, and I use one of them for outgoing calls while the others are purely for incoming.

To avoid NAT problems make sure that your /etc/asterisk/sip_nat.conf contains:
  1. nat=yes
  2. externip=x.x.x.x
Where x.x.x.x = your 'public' IP address.
Lets start by seeing a working incoming and outgoing trunk Freepbx setup :
sipgate_asterisk_config.gif
sipgate_asterisk_config.gif (7.4 KiB) Viewed 1249 times
In Outgoing settings, make sure you have fromuser and username set to your Sipgate ID.
Enter context=from-trunk in Outgoing settings if you do not allow anonymous sip calls.

Hello Paul, Thank you for your response. Much app…

If you're experiencing issues making outgoing call…

Just leave all the files in the TFTP directory and…

VoIP on the move via wifi

Great! I have been looking for a similar solution.…

Sign up for full membership