User avatar
By WelshPaul
#4070
Fax is an old technology but is still used by many businesses. Configuring your Cisco SPA112 or SPA122 with the settings listed below will help ensure the best possible result when faxing over VoIP.
  1. Select Voice in the Menu Bar, and then select either Line 1 or Line 2 depending on which line you have used for your fax, In the Network Settings section, enter the following settings:
    • Network Jitter Level: very high
    • Jitter Buffer Adjustment: no
  2. Next, in the Supplementary Service Subscription section, enter the following settings:
    • Call Waiting Serv: no
    • Three Way Call Serv: no
  3. Now, in the Audio Configuration section, enter the following settings to support T.38 fax:
    • Preferred Codec: G711u (USA) or G711a (rest of the world)
    • Use Pref Codec Only: yes
    • Silence Supp Enable: no
    • Echo Canc Enable: no
    • FAX Passthru Codec: G711u (USA) or G711a (rest of the world)
    • FAX Passthru method: ReINVITE
    • FAX Enable T38: yes
    • FAX T38 ECM Enable: yes
    • Fax Tone Detect Mode: Callee only
  4. Click Submit to save your settings.
  5. Verify that your fax machine BAUD rate is set to a speed between 7200 and 14400. I suggest 9600.
You should now be able to successfully send (and receive) a fax over your chosen VoIP provider using your Cisco SPA112 or SPA122. :P
By John
#4110
Very clear article. To be brief as possible, my continued issue is that my SPA112 will not connect to FAX machines outside my home office, with the SPA112 factory defaults and with your indicated modifications.

Are there any other modifications required or suggested?I am based in USA. The printer is set with ECM off, baud rate 9600.

The SAP112 is connected to my VOIP (ATT Uverse) and is seen on my intranet. The printer is an Epson 2760. It will take FAX data (flashing green) from the printer and attempt to send (solid green) but cannot connect to any FAX machine. I tried three numbers, two of which were a Canon number and an HP number. Do you have additional configuration ideas to try on the SPA112?
User avatar
By WelshPaul
#4111
Hi John,

The SPA112 is just one of three things required to make this work...

1. Have you checked your ISP for packet loss and low ping?

2. Who is your VoIP provider? What codec(s) do they support?
By John
#4112
Paul - many thanks for reply.

1. No. Happy to test but have no idea how. I am going to guess that the ping and loss will be low / acceptable. Line runs well at 20 MBPS. Prefer to get all the likely correct settings first.

2. To your other questions, My voip line is with at&t. Uverse. The line is indicated as active on a Uverse 2Wire router. It serves our landline. We are in the USA. No issue with sharing the fax with the voice as we rarely use the fax. Do I need to input some specific Uverse server settings on the spa112?
User avatar
By WelshPaul
#4113
John wrote:Paul - many thanks for reply.

1. No. Happy to test but have no idea how. I am going to guess that the ping and loss will be low / acceptable. Line runs well at 20 MBPS. Prefer to get all the likely correct settings first.
Run the VoIP test here: http://myspeed.visualware.com/

You will need to install BCS prior to running the test, you can download and install it from here: http://www.visualware.com/bcs/index.html

Once complete you will see the results as shown in the image below:
Screenshot (45).png
John wrote:2. To your other questions, My voip line is with at&t. Uverse. The line is indicated as active on a Uverse 2Wire router. It serves our landline. We are in the USA. No issue with sharing the fax with the voice as we rarely use the fax. Do I need to input some specific Uverse server settings on the spa112?
I don't know anything about AT&T's U-verse service. You say 'The line is indicated as active on a Uverse 2Wire router', i'm guessing that they supply you with a pre-configured VoIP router that allows you to make and receive VoIP calls over their own VoIP network? If so there should be a phone port on the router? Or, does the router connect to a PSTN wall socket?

How exactly have you setup the SPA112?

1. SPA112 connected to the mains > Ethernet cable to router.
2. Phone / fax connected to phone 1/2 port
3. Configure and register the SPA112 with a SIP provider
4. Configure SPA112 with fax settings shown in original post
5. Reboot

What is the current registration state of the SPA112? Log in to the Phone Adapter Configuration Utility as an administrator and choose Voice > Information. The Information page opens:
2706_1.png
Remember, the SPA112 needs to be registered with a VoIP provider (or pbx) directly in order to make and receive a fax or phone call. Who is the VoIP provider you're trying to register with and do you know/have the registration proxy address, username and password to hand?

Having had a quick look online regarding AT&T U-verse, I found the following:
The U-Verse service requires the customer to use a router that was designed specifically for U-Verse Internet, TV, and phone service.
Can I use a regular fax machine with the AT&T U-verse Voice service?
Yes. This service works with most fax machines when connected to the AT&T gateway In order to use a fax machine with your U-verse phone service, you need to ensure that the fax LINE connector is connected to the gateway, rather than the PHONE connector. These connectors are usually marked Line and Phone or "L" and "P", or are designated by use of small icons.
By John
#4114
I understand your questions and comments except one. I have not registered with a voip provider. I have a voip through Uverse. No proxy etc has been set up. I thought that spa112 does not require that to issue FAXs, if it can connect to an existing voip service line. Please advise? Do I need a Uverse proxy?
User avatar
By WelshPaul
#4116
Hi John,

My next port of call was to ask you if there was any reason why you hadn't connected your fax machine to the U-verse phone port on your router. If your answer was 'because I have a phone connected to it', I was going to suggest you get a double telephone adaptor which would allow you to connect your phone and fax to the same phone port on your router. Of course the only down side to that would be if your phone line is in use because your on the phone then anyone trying to fax you would get an engaged tone. (Unless you have call waiting enabled)

Anyway, i'm glad you found a solution. :)
By John
#4119
Yes. That's what I have done. The printer is located upstairs. For the record: the rj45 cable located near my printer connects downstairs to a phone line splitter. The splitter is of course attached to rj11 phone jack on the router. The printer fax rj11 cable connects to the Rj45 Jack with an adapter. Easier done than written. Again thx.
Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests

Sorry I mean to say if I do not stop autoboot the …

How to Evaluate an IP Phone System?

CISCO SPA500S

Create a call group and add the three extensions t…

Landline bridge advice

Thanks for tremendous efforts on this Paul. I'm s…