50 % 50 %
By alex01
#4152
Hi,

I've been having problems with this since Sangoma have changed default port for chan sip extensions, first they changed to 5061 and now to 5160. I have tried to change port number in sipura within line setup but it never registers.

The only way that I have been able to make it work is by changing the bind port within freepbx back to 5060.

I was wondering if anyone else has had this problem and how they have dealt with this problem.

thanks in advance
User avatar
By WelshPaul
#4154
The Sipura, Linksys and Cisco hardware usually require a hard reboot when making such changes, so...

After making the change in the Sipura GUI, save the changes and then do a hard reboot - Unplug it from the mains for 30 seconds and then plug it back in.
User avatar
By WelshPaul
#4158
Sorry i'm confused... Is your Sipura device registering directly with Sangoma or a local freepbx server?

I'm guessing here that you have a FreePBX server that is registered with Sangoma (via a chan_sip trunk) and in turn the Sipura is registered against an extension on that FreePBX server, is that correct?

If so you need to add or modify the port in the trunk configuration on the FreePBX server as follows:
Code: Select all
port=5060
It's the FreePBX server that registers with Sangoma not the Sipura device, the Sipura registers with your FreePBX server.
alex01 wrote:I am changing the port number in line configuration page for each line, I've looked but can't find anywhere that it can be changed globally.
There is no global setting on the Sipura, you need to individually change the port under the Line tab.

What model Sipura device are you using and what port is it currently set to use? If you want your Sipura to use port 5060 too then you need to also change the port on the extension it's registered against in FreePBX.
By alex01
#4160
Hi Paul,

The bind port on the freepbx server is set to 5060 which is no longer a standard port, the latest is 5160; with the bind port on freepbx changed and set at 5060 the extension registers without problem.

If I change the port on the freepbx back to 5160 and then change the port on the sipura line port number to 5160 it never registers, even after powering down and starting both the the sipura and the server. after trying the above today I changed the port back to 5060 on the server bind port and the same on the sipura, then both lines registered immediately.

the device is a sipura spa2102, I carry out the above on both lines at the same time because both are in use.
User avatar
By WelshPaul
#4161
Hmm, you still haven't confirmed if you changed the extension port as well as the bind port?

On FreePBX:
Code: Select all
Bind port under advanced SIP settings: 5160
Extension port: 5160
Sipura 2102:
Code: Select all
Voice > Line x > SIP Settings > SIP Port: 5160
You have provided a binding IP as well as the port? Also, check that your firewall isn't blocking traffic on port 5160? Check your iptables!
alex01 liked this
By alex01
#4165
Hi again Paul,
apologies for not replying sooner but I've been busy at work.
it may have something to do with me repeatedly unplugging the power cable but suddenly the sipura has been acting up and stopped working altogether, the power light is just flashing green and nothing else is happening with it. I tried to reset to factory settings via telephone but no joy. I have another on order so I have to wait till I receive replacement.
User avatar
By WelshPaul
#4167
No problem, have you ordered another SPA2101 and If so where from? They have been obsolete for years! :-o

I just noticed something - I asked you in an earlier post what model Sipura you were using and the thread title clearly states: CHANGING PORT ON SIPURA SPA 2102 :laugh:
Having one of those weeks! :nerd:

It still sounds as though the FreePBX server is blocking traffic on port 5160, did you look into that at all?
By alex01
#4174
yes you was right, in that I hadn't changed the port number in extension which I never knew was there, I thought that advanced sip settings port was global as I think it says.
I'm currently using a vigor 2910vg as an ata and it works with the 5160 port - easy when you know how!
I've ordered a pap2t na from ebay for now, thinking about a cisco SPA112 later on if I can get at good price.

Thanks for your help!
WelshPaul liked this
User avatar
By WelshPaul
#4176
I was confident that it was either an extension port issue or an iptables issue. ;-)

The SPA112's have indeed sky rocketed in price! You can't go wrong with a genuine PAP2T but you've likely purchased a fake one, check out these topics:

THINKING OF BUYING A PAP2(T) OFF EBAY? THINK AGAIN!
HOW TO CHECK IF A PAP2/PAP2T IS GENUINE?

If it is a fake, make sure it's well ventilated.
Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests

Sorry I mean to say if I do not stop autoboot the …

How to Evaluate an IP Phone System?

CISCO SPA500S

Create a call group and add the three extensions t…

Landline bridge advice

Thanks for tremendous efforts on this Paul. I'm s…