Advertisement

By Sponsor
User avatar
By WelshPaul
#1084
Struggling to get your UKDDI accounts working with your Obihai device? This guide should have you up and running in no time...

First lets configure your UKDDI account, log in here: https://www.3c.co.uk/ui/ and navigate to 3C > Numbers > List.

I am going to assume you already have your numbers allocated as I already have as shown below:
UKDDI_logged_in_a.png
UKDDI Logged In / List Numbers
UKDDI_logged_in_a.png (24.13 KiB) Viewed 2650 times
If not, click on "Allocate new" and add them.

We need to route our UKDDI numbers to the device we're going to be registering against our UKDDI account - In my case an OBi200.
Click on the "green arrow" located under the "edit" tab for the number you wish to configure as shown below:
UKDDI_Route_setup.png
UKDDI Route Numbers
UKDDI_Route_setup.png (44.63 KiB) Viewed 2650 times
Under the parameter "Route:" we need to enter the word "register" as shown in the image above, then click create.

I did this for both numbers in my list and as such I now have the following:
UKDDI_logged_in_b.png
List Numbers
UKDDI_logged_in_b.png (24.58 KiB) Viewed 2650 times
As I am in the UK there are just a few more changes to be made, click on "3C > Numbers > Options" and under the secrion "Caller ID type" select "UK (UK CLIs as 0 + area code + number, international as 00 + full number)" and click on "Update" as shown below:
UKDDI_options.png
UKDDI Options
UKDDI_options.png (46.55 KiB) Viewed 2649 times
All we need to do now is to configure the registration parameters, click on "3C > Numbers > Registration" and make the following changes:
  • Registration interval: 60
  • Caller ID type: UK (UK CLIs as 0 + area code + number, international as 00 + full number)
  • DDI format: UK (UK DDIs as 0 + area code + number, international as 00 + full number)
As shown below:
UKDDI_registration.png
UKDDI Regisatration
UKDDI_registration.png (75.58 KiB) Viewed 2597 times
That's it! Your UKDDI account is now correctly configured and all we need to do now is configure our Obihai device...

My OBi200 is at it's factory defaults, I am going to configure my device locally by entering it's IP address into my web browser. You can do the same or you can use the Obitalk Portal if you prefer.

Note: If you have already configured your Obihai device via the Obitalk Portal and later make changes locally via your web browser the Obitalk Portal may overwrite any changes you make. I recommend you continue to configure your device via the Obitalk Portal.

Log in to your OBi200 device and navigate to "Service Providers > ITSP Profile A> Sip" and look for the "ProxyServer" parameter. (It's the first one in the list)

Remove the tick from the default boxes and enter the following values:
  • ProxyServer: sip.ukddi.com
obi200_itspa.png
ITSP Profile A Proxy
obi200_itspa.png (106.5 KiB) Viewed 2648 times
And:
  • RegisterExpires: 60
image.jpg
ITSP Profile A Register Expires
image.jpg (72.13 KiB) Viewed 2600 times
Scroll down to the bottom of the page and click on the "submit" button as shown below:
obi200_itspa_submit.png
ITSP Profile A Submit Changes
obi200_itspa_submit.png (33.24 KiB) Viewed 2648 times
Now navigate to "Voice Services > SP1 Service" and enter your UKDDI SIP Credentials:
  • AuthUserName: ukddi_1253232
  • AuthPassword: DSiKIv6Yc0TP
Note: Make sure you remove the tick from the use default option box located next to each parameter.
obi200_voice_sp.png
SP1 Service
obi200_voice_sp.png (153.1 KiB) Viewed 2643 times
Click on the "Submit" button to save the changes and then click on the "Reboot" button located on the top right of the page as shown above to reboot your device.

Your device is now successfully registered against your UKDDI account and you should be able to receive inbound calls from your UKDDI number(s) on your Obihai device. :thumbsup:

Advertisement

By Sponsor
User avatar
By WelshPaul
#1086
Morning Dave,

The password shown above was changed before I submitted the tutorial. I don't actually use UKDDI myself and only created the account to do the guide. Oh and the phone numbers used in the above guide were also deleted before I uploaded the tutorial. ;)
User avatar
By WelshPaul
#1704
GSD1 wrote:WelshPaul,

Thanks for the write up but I am still having problems. When I call the UKDDI number it rings fine but when I pick up the phone the calling phone still keeps on ringing.
This sounds like a firewall/nat issue, have you tried disabling SIP ALG on your router?
By GSD1
#1706
WelshPaul wrote:
GSD1 wrote:WelshPaul,

Thanks for the write up but I am still having problems. When I call the UKDDI number it rings fine but when I pick up the phone the calling phone still keeps on ringing.
This sounds like a firewall/nat issue, have you tried disabling SIP ALG on your router?
Not sure how to disable SIP/ALG settings. I have freephoneline.ca on SP1 on the Obi200 using 6060.

My modem is an Technicolor TG852N
By GSD1
#1711
gsmlnx wrote:Just follow the instructions at this UK ISP website https://support.aa.net.uk/Router_-_TG58 ... Forwarding and look for the section Application Layer Gateways - Disabling the SIP ALG
Thanks I will try this. Is this option reversible if I have any problems?
By SteveAtVoIP2Go
#1724
This thread reminded me to experiment with UKDDI and I ran into a problem setting the Route. It says it should be in the form:

sip:<number>@<host>

I have tried many different SIP URI's but I cannot get anything to stick. I have tried:

[email protected]
[email protected]
sip:[email protected]
sip:[email protected]
sip:[email protected]:Port

Has anyone managed to correctly setup a Route in UKDDI?
By SteveAtVoIP2Go
#1725
Solved it!

For anyone suffering the same pain as me, you should know that the phone number list does not refresh after you define a route. It continues to show as empty even though you may enter route's over and over like I did. You need to use the Refresh button on your web browser to manually refresh the list :thumbsup:
User avatar
By WelshPaul
#1726
SteveAtVoIP2Go wrote:This thread reminded me to experiment with UKDDI and I ran into a problem setting the Route. It says it should be in the form:

sip:<number>@<host>

I have tried many different SIP URI's but I cannot get anything to stick. I have tried:

[email protected]
[email protected]
sip:[email protected]
sip:[email protected]
sip:[email protected]:Port

Has anyone managed to correctly setup a Route in UKDDI?
SteveAtVoIP2Go wrote:Solved it!

For anyone suffering the same pain as me, you should know that the phone number list does not refresh after you define a route. It continues to show as empty even though you may enter route's over and over like I did. You need to use the Refresh button on your web browser to manually refresh the list :thumbsup:
I had the same issue as you when I played around with their service a while back, very frustrating.
By GSD1
#1728
gsmlnx wrote:Just follow the instructions at this UK ISP website support.aa.net.uk/Ro ... Forwarding and look for the section Application Layer Gateways - Disabling the SIP ALG
Thank you gsmlnx and Welsh Paul, disabling SIP ALG fixed the problem. Now my parents can call me in Canada by dialing a local UK DDI number.

Any ideas on a local UK Voip provider that I set an Obi100 unit up for them in the UK?

Thanks
By GSD1
#1729
SteveAtVoIP2Go wrote:This thread reminded me to experiment with UKDDI and I ran into a problem setting the Route. It says it should be in the form:

sip:<number>@<host>

I have tried many different SIP URI's but I cannot get anything to stick. I have tried:

[email protected]
[email protected]
sip:[email protected]
sip:[email protected]
sip:[email protected]:Port

Has anyone managed to correctly setup a Route in UKDDI?
What's the benefit of routing via an IP?

Advertisement

By Sponsor

Hello, It could be the SPA122 that's faulty, the …

VOIP JOB needed

This is an independent VoIP forum, we are not a Vo…

Newbie help!

I recommend Voipfone! They offer a pay go service …

Gigaset N300A IP

@VoipIT I doubt it. From my understanding ther…

Sign up for full membership