VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
User avatar
By WelshPeter
Posts Likes Avatar Topics
#5888
The HT813 arrived today. I can receive calls on the PSTN number and the VOIP number. If I remove the ethernet cable it defaults to calling via the PSTN. The only bit I'm stuck on is making a call on VOIP. I've played about with the settings, ONE AT A TIME, but drawn a blank. Do the screenshots give you any clues as to what I'm doing wrong Paul?
Image
Image
Image
0
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#5890
Are you saying that all outbound calls are going out via the PSTN line and that you're unable to route any via your VoIP line?

Having read the user manual here, it states:
Grandstream wrote:Placing a Phone Call
To make the outgoing calls using your HT813
1. Pick up the handset of the connected phone.
2. Dial the number directly and wait for 4 seconds (Default “No Key Entry Timeout”); or
3. Dial the number directly and press # (Use # as dial key” must be configured in web configuration).
I haven't used a HT813 myself but as far as I am aware, outbound calls should be routed out over VoIP by default. To route a call via the PSTN line you need to manually dial *00 first or match a dial plan string. e.g {L: 01792x+} - calls that start with 01792 are immediately forwarded to the PSTN line.

The manual does mention the following:
Grandstream wrote:One Stage Dialing
This feature is applicable for VoIP to PSTN calls. Any VoIP extension may dial directly to a local PSTN number if the one-stage dialing feature is activated. This feature is configured under the FXO Configuration page and requires SIP Server configuration and support. The special dial plan feature must be activated in the SIP Server. An outbound call will be sent directly to the assigned FXO port account, where there the HT813 will initiate a call to the local CO. The RequestURI header in the INVITE message contains the phone number used to initiate the call to the local CO.
But this should only come into play when remotely use a PSTN line to initiate a call. Just in case, make sure that setting is disabled and upgrade the device to the latest firmware.
0
User avatar
By WelshPeter
Posts Likes Avatar Topics
#5897
Thanks Paul. I did a factory reset and started again, so one step at a time. I can now make calls and receive PSTN calls but if I don't answer within ten seconds the call is dumped and I get what can only be described as an error tone. I've searched through all the settings for "timeout", and although there are several hits, nothing that looks promising. Any calls to the VOIP number get a number unobtainable message or tone. At the moment the calls to the VOIP number are not important, but the ten second timeout makes the thing unusable.
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#5898
Ok, I am guessing that after you factory reset the device all you have done is add your VoIP credentials. Who is your VoIP provider? I need to know this before I can help you further.

Don't forget to apply the following UK configuration here. Do not use the dial plan in the above link, stick with the default one for now.
WelshPeter liked this
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#5900
Enjoyed our chat on the phone @WelshPeter. 😀

I just wanted to remind you about disabling remote access to your HT813. It's using the default username/password so anyone can gain access to it! Also, as you provided me with your SIP account information, I recommend that you change your passwords too (for peace of mind).

Enjoy your new setup and take care. 👍
WelshPeter liked this
0
0
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#5907
Great! Go to the "ADVANCED SETTINGS" page and enter "fm.grandstream.com/gs" in the "Firmware Server Path" and "Config Server Path" fields. Make sure that "HTTP" is selected for "Firmware Upgrade and Provisioning" parameter. Like this:

Image
If you're device has been removed from the provisioning server these parameters won't change. If you find that both "Firmware Server Path" and "Config Server Path" fields change after a period of time, the device is still being redirected to a provisioning server.

On another note, I have put together a UK dial plan for the Grandstream HT813 that you can use (if you're feeling adventurous). It's here: @UKVoIPForums @ Grandstream HT813 UK Dial Plan

Simply replace the existing "Dial Plan: { x+ | \+x+ | *x+ | *xx*x+ }" parameter found in both "FXS PORT" and "FXO PORT" configuration pages. To test simply dial 17070 and the call should route via your PSTN line (it's a free call to BT Line Test Facilities), dial any landline number and it should route via port5060.net. Make any additional changes as you see fit, any problems revert back to the default dial plan { x+ | \+x+ | *x+ | *xx*x+ } but I I'm confident it's all good.
0
Zoiper BLF not working

Hi all, Just seeing if anyone has got Zoiper on the de…

R.I.P. Voipfone User Forum

:cry: :cry:

SITE MAINTENANCE - 8/8/2020

Maintenance complete All work has been completed an…

Snom setup wizard

Thanks for trying. In that case, I've no idea what's go…

Sign up for VIP membership