Get help with installing, upgrading and running a PBX such as Asterisk.
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6010
Below is my Sipgate Basic PJSIP configuration that I use with my FreePBX 15.0.16.78 setup. So far so good! :nerd:

First thing you will need to do is enable the "SIP Channel Driver" to use both chan_sip and chan_pjsip. You can do that by navigating to the Settings > Advanced Settings configuration page and scrolling down until you see the "SIP Channel Driver" setting. Make sure that "both" is selected in the dropdown box. If it isn't, make the change and click "Submit" to save it and then "Apply Changes" to implement it.

Now that's out of the way, let's create a Sipgate Basic PJSIP Trunk...
  1. Navigate to Connectivity > Trunks > + Add Trunk > Add SIP (chan_pjsip) Trunk page.
    You should be at the following screen:
    Image
  2. Under the "General" tab section make the following changes:
    • Trunk Name = Sipgate-(SIP-ID)
    • Outbound CallerID = (PHONE-NUMBER)
    It should look something like this:
    Image
  3. Click on the "pjsip Settings" tab and in the "General" tab section make the following changes:
    • Username = (SIP-ID)
    • Secret = (SIP-PASSWORD)
    • Authentication = Outbound
    • Registration = Send
    • Language Code = English - United Kingdom
    • SIP Server = sipgate.co.uk
    • SIP Server Port = 5060
    • Context = from-trunk
    • Transport = 0.0.0.0-udp
    Again, it should look like this:
    Image
  4. While still in the "pjsip Settings" tab click on the "Advanced" tab and make the following changes:
    • Forbidden Retry Interval = 20
    • Fatal Retry Interval = 20
    • General Retry Interval = 20
    • Expiration = 600
    • Qualify Frequency = 20
    • Contact User = (SIP-ID)
    • From Domain = (YOUR-IP)
    • From User = (SIP-ID)
    • Client URI = sip:(SIP-ID)@sipgate.co.uk:5060
    • Server URI = sip:sipgate.co.uk:5060
    • AOR Contact = sip:(SIP-ID)@sipgate.co.uk:5060
    • Match (Permit) = sipgate.co.uk
    You can leave the rest at their defaults.
    Image
  5. Finally click on the "Submit" button to save your changes and then "Apply Changes" to implement them.
Additional information on how to convert extensions from chan_sip to chan_pjsip can be read here: WelshPaul @ FREEPBX - New tool to assist converting from SIP to PJSIP

NOTE: Replace the following (in the above configuration) with your real Voipfone credentials:
  1. (SIP-ID) = Your Sipgate Basic SIP-ID number.
  2. (PHONE-NUMBER) = Your Sipgate Basic Phone Number
  3. (SIP-PASSWORD) = Your Sipgate Basic SIP Password.
  4. (YOUR-IP) = Your IP Address (Find it here: Settings > Asterisk SIP Settings > NAT Settings > External Address)
ostridge liked this
0
0
0
User avatar
By ostridge
Posts Likes Avatar Topics
#6205
WelshPaul wrote: Mon 9th Nov 2020, 22:23 Below is my Sipgate Basic PJSIP configuration that I use with my FreePBX 15.0.16.78 setup. So far so good! :nerd:

[*]Click on the "pjsip Settings" tab and in the "General" tab section make the following changes:
  • Username = (SIP-ID)
  • Secret = (SIP-PASSWORD)
  • Authentication = Outbound
  • Registration = Send
  • Language Code = English - United Kingdom
  • SIP Server = sipgate.co.uk
  • SIP Server Port = 5060
  • Context = from-trunk
  • Transport = 0.0.0.0-udp
[*]While still in the "pjsip Settings" tab click on the "Advanced" tab and make the following changes:
  • Forbidden Retry Interval = 20
  • Fatal Retry Interval = 20
  • General Retry Interval = 20
  • Expiration = 600
  • Qualify Frequency = 20
  • Contact User = (SIP-ID)
  • From Domain = (YOUR-IP)
  • From User = (SIP-ID)
  • Client URI = sip:(SIP-ID)@sipgate.co.uk:5060
  • Server URI = sip:sipgate.co.uk:5060
  • AOR Contact = sip:(SIP-ID)@sipgate.co.uk:5060
  • Match (Permit) = sipgate.co.uk
You can leave the rest at their defaults.
Image

Additional information on how to convert extensions from chan_sip to chan_pjsip can be read here: WelshPaul @ FREEPBX - New tool to assist converting from SIP to PJSIP

NOTE: Replace the following (in the above configuration) with your real Voipfone credentials:
  1. (SIP-ID) = Your Sipgate Basic SIP-ID number.
  2. (PHONE-NUMBER) = Your Sipgate Basic Phone Number
  3. (SIP-PASSWORD) = Your Sipgate Basic SIP Password.
  4. (YOUR-IP) = Your IP Address (Find it here: Settings > Asterisk SIP Settings > NAT Settings > External Address)
The above failed to register until
I changed the
From Domain = YourDDNSaddress-name (such as 'my23.dyndns.com') / OR use a 'fixed external-IPaddress' for your server

I deleted the settings (which get auto generated by fPBX ) for the following 3 lines
[*]Client URI =
[*]Server URI =
[*]AOR Contact =
Also the next line requires the sipgate.co.uk IP addresses as follows
[*]Match (Permit) = 217.10.79.23/20,217.10.68.149/20,217.10.68.151/20,217.10.68.151/20
Regards
0
User avatar
By ostridge
Posts Likes Avatar Topics
#6243
To fine tune my post above I put back the Server URI as below which works fine.


Client URI =
Server URI = sip:(SIP-ID)@sipgate.co.uk:5060
Media Address =
AOR =
AOR Contact =
Match (Permit) = 217.10.79.23/20,217.10.68.149/20,217.10.68.151/20,217.10.68.151/20
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6244
Deleting fields such as AOR, AOR Contact, Client URI etc will result them being automatically generated behind the scenes.

Example - Even though you have nothing in the field AOR Contact, it still uses sip:(SIP-ID)@sipgate.co.uk:5060 and thats why you don't have an issue leaving it empty. A future update could change how its populated and that could cause a problem and so that's why I have it in my configuration above.

You don't have to use IP's, it's recommended that you actually use domain names. Most prefer to use IP addresses and there is no harm in this, unless they change at some point of course.

More info here:
https://wiki.asterisk.org/wiki/display/ ... istrations

I just setup two servers (Digitalocean VPS & Vultr VPS) and tested my initial configuration using two different Sipgate UK Basic accounts and both work just fine. 🙂
ostridge liked this
0
User avatar
By airmarshall
Posts Avatar
#6275
Thanks for this post. I now have my sipgate uk registered using Sipgate.

However, I now need a little help with my inbound route as it's stopped passing the calls to the ring group.

@WelshPaul do you mind posting your inbound route please?

When calling my sipgate number currently, my PBX answers the call with: "The number you have dialed is not in service, please check and try again. <SIP-ID>"
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6277
0
Cisco 8841 3PCC

Before we go any further... Can you verify that the d…

VIP Membership

Good stuff, I see it now. Thanks @WelshPaul !

You can register multiple devices against the same SI…

I'm sure this is a config problem as it affects 3 off S…

Sign up for VIP membership