VoIP hardware is developing fast - this is where you ask all those “how do I make my SIP Telephone, Adapter or Asterisk box work with my voip provider?” questions.
User avatar
By WelshPeter
Posts Likes Avatar Topics
#5888
The HT813 arrived today. I can receive calls on the PSTN number and the VOIP number. If I remove the ethernet cable it defaults to calling via the PSTN. The only bit I'm stuck on is making a call on VOIP. I've played about with the settings, ONE AT A TIME, but drawn a blank. Do the screenshots give you any clues as to what I'm doing wrong Paul?
Image
Image
Image
0
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#5890
Are you saying that all outbound calls are going out via the PSTN line and that you're unable to route any via your VoIP line?

Having read the user manual here, it states:
Grandstream wrote:Placing a Phone Call
To make the outgoing calls using your HT813
1. Pick up the handset of the connected phone.
2. Dial the number directly and wait for 4 seconds (Default “No Key Entry Timeout”); or
3. Dial the number directly and press # (Use # as dial key” must be configured in web configuration).
I haven't used a HT813 myself but as far as I am aware, outbound calls should be routed out over VoIP by default. To route a call via the PSTN line you need to manually dial *00 first or match a dial plan string. e.g {L: 01792x+} - calls that start with 01792 are immediately forwarded to the PSTN line.

The manual does mention the following:
Grandstream wrote:One Stage Dialing
This feature is applicable for VoIP to PSTN calls. Any VoIP extension may dial directly to a local PSTN number if the one-stage dialing feature is activated. This feature is configured under the FXO Configuration page and requires SIP Server configuration and support. The special dial plan feature must be activated in the SIP Server. An outbound call will be sent directly to the assigned FXO port account, where there the HT813 will initiate a call to the local CO. The RequestURI header in the INVITE message contains the phone number used to initiate the call to the local CO.
But this should only come into play when remotely use a PSTN line to initiate a call. Just in case, make sure that setting is disabled and upgrade the device to the latest firmware.
0
User avatar
By WelshPeter
Posts Likes Avatar Topics
#5897
Thanks Paul. I did a factory reset and started again, so one step at a time. I can now make calls and receive PSTN calls but if I don't answer within ten seconds the call is dumped and I get what can only be described as an error tone. I've searched through all the settings for "timeout", and although there are several hits, nothing that looks promising. Any calls to the VOIP number get a number unobtainable message or tone. At the moment the calls to the VOIP number are not important, but the ten second timeout makes the thing unusable.
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#5898
Ok, I am guessing that after you factory reset the device all you have done is add your VoIP credentials. Who is your VoIP provider? I need to know this before I can help you further.

Don't forget to apply the following UK configuration here. Do not use the dial plan in the above link, stick with the default one for now.
WelshPeter liked this
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#5900
Enjoyed our chat on the phone @WelshPeter. 😀

I just wanted to remind you about disabling remote access to your HT813. It's using the default username/password so anyone can gain access to it! Also, as you provided me with your SIP account information, I recommend that you change your passwords too (for peace of mind).

Enjoy your new setup and take care. 👍
WelshPeter liked this
0
0
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#5907
Great! Go to the "ADVANCED SETTINGS" page and enter "fm.grandstream.com/gs" in the "Firmware Server Path" and "Config Server Path" fields. Make sure that "HTTP" is selected for "Firmware Upgrade and Provisioning" parameter. Like this:

Image
If you're device has been removed from the provisioning server these parameters won't change. If you find that both "Firmware Server Path" and "Config Server Path" fields change after a period of time, the device is still being redirected to a provisioning server.

On another note, I have put together a UK dial plan for the Grandstream HT813 that you can use (if you're feeling adventurous). It's here: @UKVoIPForums @ Grandstream HT813 UK Dial Plan

Simply replace the existing "Dial Plan: { x+ | \+x+ | *x+ | *xx*x+ }" parameter found in both "FXS PORT" and "FXO PORT" configuration pages. To test simply dial 17070 and the call should route via your PSTN line (it's a free call to BT Line Test Facilities), dial any landline number and it should route via port5060.net. Make any additional changes as you see fit, any problems revert back to the default dial plan { x+ | \+x+ | *x+ | *xx*x+ } but I I'm confident it's all good.
0
User avatar
By BrianG61UK
Posts Avatar
#6186
WelshPaul wrote: Mon 27th Jul 2020, 15:37 Great! Go to the "ADVANCED SETTINGS" page and enter "fm.grandstream.com/gs" in the "Firmware Server Path" and "Config Server Path" fields. Make sure that "HTTP" is selected for "Firmware Upgrade and Provisioning" parameter. Like this:

Image
If you're device has been removed from the provisioning server these parameters won't change. If you find that both "Firmware Server Path" and "Config Server Path" fields change after a period of time, the device is still being redirected to a provisioning server.
Could you explain this further? It doesn't really make any sense to me at all and I like to think I understand this kind of stuff better than average.

What does telling the box to fetch it's configuration and firmware from "fm.grandstream.com/gs" achieve?
As far as I can tell you always get an error. It's like that's a dummy string and nothing is there.
You can tell it to fetch it's firmware from "firmware.grandstream.com" or "firmware.grandstream.com/BETA" and that will work and keep your firmware up to date.
However personally I put dont.use.invalid as the server to fetch the configuration since I do not want any possibility of Grandstream changing my configuration or of them knowing every time I reboot the box. Am I wrong?
0
User avatar
By WelshPaul
Posts Signature Likes Avatar Topics
#6187
Hi, The fm.grandstream.com/gs URL is not a dummy string, its Grandstream's provisioning URL that is hardcoded into their firmware. :nerd:

The reason I told the original poster above to enter fm.grandstream.com/gs? Because his device was "owned" by yay.com even though he purchased it outright from NetXL. His device provisioning URL's were overwitten to use yay.com's provisioning servers URL's. As a result, some of his settings were being overwritten. (Yes, I could have just told him to remove the custom URL’s and leave the fields empty, but should he reset the device in the future the problem would return.) I told him to contact NetXL/yay.com and requested they remove the device from their provisioning server. They replied and confirmed they had removed his device. To confirm they had removed his device I got him to enter fm.grandstream.com/gs back into his devices configuration (if it doesn’t change, the device has been removed and is no longer on any provisioning server list).

https://www.grandstream.com/sites/defau ... public.pdf
Grandstream wrote:Upon powering up a device, it will contact the Grandstream provisioning server fm.grandstream.com/gs first, and then get redirected to a TFTP/HTTP server where it pulls out the firmware files and the configuration files.
An example...

Let’s say Voipfone want to supply their customer base with HT813's but they want to control what firmware version is installed and have them automatically setup, so their customers just need to plug them in and their ready to go. How do they do this?

Well, Voipfone will need to have each device pre-configured to include their provisioning server’s URL so that when the device is booted up for the first time, the required firmware version is installed, and the user’s configuration is pushed to the device so they can make and receive calls without having to do anything. This could be achieved by having Grandstream create a custom firmware version where fm.grandstream.com/gs is replaced with the Voipfone custom provisioning URL or Voipfone could manually enter this into each device before having it shipped to the customer. Neither are ideal.

If Voipfone were to manually do this, it would be time consuming and expensive. Also, should an end user ever factory reset the device at any point the custom URL Voipfone manually entered into the device would be erased and replaced with the default fm.grandstream.com/gs preventing it from auto provisioning in the future. Custom firmware isn’t ideal either, there are hundreds of thousands of VoIP providers out there worldwide and they all have their own provisioning servers. That’s a lot of custom firmware requests!

So, manufacturers have their own provisioning servers, and they bake its URL into the firmware so upon first boot the device checks the provisioning server to see if it’s “owned” by any VoIP company and if it is, the URLs are updated with the custom URL’s and provisioning begins. This method works even when a device is factory reset.
BrianG61UK liked this
1
0

Thank you for the information. I have my outgoing calls…

Below is my Sipgate Basic PJSIP configuration that I …

Hi, I'm interested in your advice and or services to h…

Replacing my phone with a laptop

Hi Miguel, Thank you for your reply. I am sorry it's l…

Sign up for VIP membership