If it's about VoIP, SIP or Internet Telephony but it doesn't seem to fit anywhere else, post it here.
User avatar
By mpmc
Posts Signature Likes Avatar Topics
Hi folks,

Been a while, hope everyone here is well. This post is going to be rather technical so it's best I break it down a bit.

* Raspberry Pi 4 4GB running Freepbx
* Quectel 4G modem for calls / data (as fallback)
* Sipgate "Basic" Starter landline
* Yeastar TA100 for Analogue to SIP
* Virgin Mobile SIM that appears to roam on Vodafone
* Sky Mobile SIM On VM02 (as test sim)
* To make life a bit easier I've configured PJSIP to use Sipgate's STUN server

Now onto the issues:
It would appear (unless I'm going crazy) that Vodafone are hindering VOIP calls not going through themselves. Sipgate will register fine & stay online but NO audio in/out. No matter what I do.

I assumed it was some sort of configuration issue at first, but I've already broken everything down! However the EXACT same configuration when using the Sky SIM works perfectly fine. I only swap the SIMs over and it all works great. :confounded:

The Freepbx logs for both SIMs are identical as far as Asterisk is concerned the calls are connected but there is absolutely no audio when using the VM on Vodafone SIM. With/without the STUN server, and I've tried a few!


I know what you're going to say, just use the Sky VM02 SIM and honestly it looks like I will have to but for Vodafone to mangle SIP like this is absolutely disgusting but in no way surprising. Mobile calls and data otherwise are fine.
User avatar
By @UKVoIPForums
Posts Likes Avatar Topics
That's an odd one! Both Vodafone and O2 use CGNAT and so that can't be the reason why RTP traffic is being lost. Anyway, it might not be a Vodafone issue per se but a Virgin Mobile one. Have you tried putting the Virgin Mobile SIM into a phone and tested it using a free Softphone app?
User avatar
By mpmc
Posts Signature Likes Avatar Topics
@@UKVoIPForums, Yes :) It's the reason I got the Sky SIM as well as two different modems.

I also noticed that incoming VOIP calls via the Sky SIM come through instantly and audio works perfect. With the VM SIM it can take up to 30 > seconds for the calls to even hit Asterisk with no audio. outgoing via the Sky SIM fine too, VM SIM everything "connects" but no audio. When going via our Virgin broadband all is well.

It's an odd one indeed. I may have to swap to the O2 SIM.
Ringback when busy

I have recently changed over to VOIP with Fibrus which …

Multiline VoIP providers?

I am aware that for people using a full blown VoIP phon…

Hi guys i have been trying to setup a grandstream ht801…

@@UKVoIPForums , Yes :) It's the reason I got the Sky…

Sign up for VIP membership